
        
            
                
            
        

    
Excel Training Manual for
Financial Professionals 

First Edition 

Copyright © 2016 Anton Du Plessis
All rights reserved. No part of this publication may be reproduced, distributed or transmitted in any form
or by any means, including photocopying, recording or other electronic or mechanical methods, without
the prior written permission of the publisher.

First Edition, 2016 
Russell Templar Ltd.

Registered in England and Wales
Company Number: 10187229

14 Meadowview, Winnersh, RG41 5PD, UK 

www.russelltemplar.com 

ISBN-13: 978-1539533283 

ISBN-10: 153953328X
About the Author
I have worked in the IT and financial fields since 1997. I have many years’ experience as a software
developer and I am also a chartered accountant. In my experience in both the IT and financial fields Excel
has  always  been one of the main  software packages  I have used  over the years.  I started using
spreadsheets before my computer came with a mouse. When I started using spreadsheets the software
was called Lotus 1-2-3 and together with WordPerfect you could “run” an office. Over the years my skills
grew with the various versions of Excel that was released. In 2010 I qualified as a chartered accountant 
at one of the big four audits firms where I was also introduced to the world of training. I quickly realised
that I seemed to work quicker and more efficient in Excel than most of my colleagues. This was not 
because my colleagues did not have IT skills or where new to Excel. They just needed to be shown
certain skills and techniques to sharpen the skill they already had. From that need came this book, that I 
originally used as a training manual for a one day Excel course. 

I moved to the UK in 2013 and have been working in the financial field here as well and saw the same 
need for the training here. Although it is currently not practical for me to run full time training courses I 
have decided to publish my training manual aimed specifically at financial professionals. 

Anton, 2016
First Edition 
For Sue, Fiona, Paul, Siobhan, Hiwot, Mark and Irina. These have been my colleagues in recent times.
All brilliant people that put up with me in the last 3 years. I sometimes trained them against their will but 
they all inspired me to write and publish my book. Funny enough not this book. That book, also on Excel 
will see the light soon. 

And always my wife Janine whose love and support push me further than I ever thought I could go.
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Background

This book is written mainly for financial professionals like auditors and accountants. I have worked in IT, 
audit and accounting and presented Excel courses for financial staff for the last few years. This book can 
be used as a self-study course or trainers can use it as course material.

I am asked if this course is a beginner, intermediate or advanced level. In my experience most financial 
staff have an average to good understanding of Excel. If you had to compare this course with most
generic Excel courses out there I would place it between intermediate and advanced. But as this course
is aimed at financial professionals with an established Excel understanding, I refrain from calling it an
advanced course. Most everyday users of Excel can benefit from this course and I would not recommend
it for someone that is using Excel for the first time.

In my experience a day of instructor led time is needed for this course. If you are using this course as
self-study I would suggest tackling one topic at a time, including the exercises. It is suggested that you
buy a book for each participant if you use this book as course material.

This course was originally written with Excel 2010 in mind. It was updated for Excel 2013 with no change 
to the content, just the screen shots changed. As this course is aimed at fundamental techniques in Excel
it is still applicable even with Excel 2016. 

This course comes with exercises and solutions. These can be downloaded at the link provided below.
You can download the exercises and solutions before you start the course. This course is aimed at adult 
learners and caters for different styles of learning. For most styles of learning and instructor led courses
it is best to only reference the solutions after at least attempting the exercises first. 

Downloads  

You can download the exercises and solutions at:
www.russelltemplar.com/books
Before we begin… 

The Ribbon 

The menu in Excel is referred to as a ribbon. A ribbon is divided into Tabs, Groups, and Buttons, the
reason for this ribbon is efficiency. You should be able to perform most tasks in Excel in only two clicks. 

In the exercises in this course if you need to click on the Cut button it will be displayed as:  

Click [Home][Clipboard][Cut]  

Some of the buttons have multiple options if you click on them, in those cases there will be more square
brackets e.g.:  

Click [Home][Styles][Conditional Formatting][Highlight Cells Rules][Duplicate Values…]  

Shortcut keys
In this course there are
 shortcut keys for many of the functions e.g. Ctrl+C for Cut and Ctrl+V for Paste. 
These shortcuts make it more effective to perform certain tasks. At the back of this manual you will find
a comprehensive list of shortcuts you could use in Excel.

Cell selection notation  

Cells are referred to by their column letter or row number: B2 will be the second cell in column B.  

In this course you often have to select multiple cells. When you have to select cells B2:D9 (with the : in 
between) you need to select all the cells that encompass those references. 

Course content 
This course contains more sections than can usually be covered in one day. This is done for two reasons. 
First we can adapt the course according to the level of the audience. Some sections may be left out but
you can still do them in your own time if you wish to. Secondly this manual is as complete as possible; 
you may need some of these sections later on and can then just refer back to your manual.

Course Material 

You can download the exercises and solutions at: 

www.russelltemplar.com/books 

Excel parts  

On the next page you will find a screenshot of Excel with some areas identified 

4  

End of Exercises
None of the exercises in this manual explain to you what to do once you have completed an exercise.
That will be up to you. You can either save to file or not. Remember you can always get the clean
exercises from the internet or you can make a copy of them before you start, if you want to re-do any of 
them.

Working with cells and worksheets 

Selecting cells 

Selecting adjacent multiple cells  

Method
1.  Click on the first cell and hold the left mouse button down

2. Drag the mouse over all the cells you want to select

3.  Release the mouse button

OR 
1.  Select the first cell by clicking in it

2.  Move the worksheet so that the cell that will encapsulate all the data is visible

3.  Press and hold Shift

4.  Click the cell that encapsulate all the data

5.  Release Shift

Selecting non-adjacent multiple cells  

Method
1.  Select the first cell by clicking in it

2.  Press on hold the Ctrl button

3.  Now select all the cells you want to select 

4.  Release the Ctrl button

Selecting all cells in a worksheet 

1.  Click the Select All button 

OR  

1.  Press Ctrl + A 

Shortcut: If the worksheet contains data, and the active cell is above or to the left of the data, pressing 
Ctrl+A selects the current region. Pressing Ctrl+A a second time selects the entire worksheet.  

Merge and unmerge cells 
When you merge two or more adjacent horizontal or vertical cells, the cells become one larger cell that
is displayed across multiple columns or rows. When you merge multiple cells, the contents of only one
cell (the upper-left cell) appear in the merged cell. The contents of the other cells that you merge are
deleted. After merging cells, you can split a merged cell into separate cells again. If you don't remember
where you have merged cells, you can use the Find command to quickly locate merged cells.

Merge adjacent cells 

Method 

1. Select two or more adjacent cells that you want to merge
Note
: Make sure that the data that you want to display in the merged cell is contained in the
upper-left cell of the selected range. Only the data in the upper-left cell will remain in the merged
cell. Data in all the other cells of the selected range will be deleted. Copy any other data you 
need to another location on the worksheet before merging.

2. On the Home tab, in the Alignment group, click Merge and Center 

The cells will be merged in a row or column, and the cell contents will be centred in the merged
cell. To merge cells without centring, click the arrow next to Merge and Center, and then click 
Merge Across or Merge Cells. 

3. To change the text alignment in the merged cell, select the cell, and then click any of the
alignment buttons in the Alignment group on the Home tab  

Split a merged cell  

Method
1.
 Select the merged cell that you want to unmerge

2. To split the merged cell, click Merge and Center, or click the arrow next to Merge and Center, 
and then click Unmerge Cells

Immediately after merging cells, you can also unmerge them by clicking Undo on the Quick
Access Toolbar, or by pressing CTRL+Z 

3. The contents of the merged cell will appear in the upper-left cell of the range of split cells 

Find merged cells  

Method
1.  On the Home tab, in the Editing group, click Find & Select 

2. Click Find 

3.  On the Find tab, click Options, and then click Format 

Note: If you don't see the Format button, click Options
4.  On the 
Alignment tab, under Text control, select the Merge cells check box, and then click 
OK

5.  Do one of the following:

- To find the next occurrence of a merged cell, click Find Next  

Excel selects the next merged cell on the worksheet 

- To find all merged cells, click Find All 

Excel displays a list of all merged cells in the bottom section of the Find and Replace dialog 
box. When you select a merged cell in this list, Excel selects that merged cell on the worksheet  

Note: Formula references in other cells are adjusted automatically to use the cell reference of the
merged cell. 

Because sorting requires that all cells to be sorted are using the same size, you cannot sort a range
that contains a combination of merged and unmerged cells. 

Inserting a Worksheet  

Method
1. Click the Insert Worksheet tab at the bottom of the screen 

OR
1. To insert a new worksheet in front of an existing worksheet

2. Select that worksheet

3. On the Home tab, in the Cells group, click Insert, and then click Insert Sheet

OR
1.
 Right click the tab of an existing worksheet 

2. Click Insert

3. On the General tab, click Worksheet

4. Click OK

OR 

1. Press Shift + F11 

Short cut: To add a new worksheet press  Shift + F11 

Deleting a Worksheet 

Method
1.
 Right click on the worksheet tab you want to delete

2.  From the Shortcut menu, select Delete

3. Select OK

OR 
1.  Select the
 worksheet or worksheets that you want to delete.

2.  On the Home tab, in the Cells group, click the arrow next to Delete, and then click Delete 
Sheet

Beware: Once you have deleted a Worksheet in Excel you will not be able to undo your action.  

Copy a Worksheet 

Using the mouse
Method
1. Press and hold
 Ctrl

2. Drag the worksheet tab of the worksheet you want to copy to its new location, releasing the
mouse button when the black triangle is in the desired location

3. Release Ctrl

Shortcut Menu 

Method
1. Right click the tab of the worksheet you want to copy  

2. From the Shortcut menu, select Move or Copy… 

3. In the
 Move or Copy dialogue box, from the To Book drop down list, select the desired
workbook 

4. In the Before Sheet list box, select the worksheet before which the copied worksheet will 
appear 

5. Select the Create a Copy check box 

6. Select OK

Move a Worksheet 

Using the mouse
Method 

1. Drag the worksheet tab of the worksheet to its new location, releasing the mouse button when 
the black triangle is in the desired location 

Shortcut Menu 

Method 

1. Right click the tab of the worksheet you want to copy 

2.  From the Shortcut menu, select Move or Copy… 

3.  In the
 Move or Copy dialogue box, from the To Book drop down list, select the desired
workbook

4.  In the Before Sheet list box, select the worksheet before which the selected worksheet will
appear

5. Select OK

Note: When you need to view more than one workbook at a time: 

On the View tab, the Window group, select Arrange All 

Select Tile or Vertical 

This is also useful for Copying or Moving worksheets 

Renaming a Worksheet 

You can rename any worksheet in an Excel workbook. The name can be up to 31 characters long and
cannot contain the following characters : ( ) / \ ? * 

Method
1. On the Sheet tab bar, right click the sheet tab that you want to rename, and then click Rename 

2. Enter the new name 

3. Press Enter 

OR 

1. On the Sheet tab bar, double click on sheet tab that you want to rename 

2. Enter the new name 

3.  Click anywhere on the sheet to continue  

Navigating Worksheets  

Method
1. Right click on the worksheet navigation arrows 

2.  Select the worksheet you want to navigate to 

Short cut: You can also Press Ctrl & Page Up or Page Down to navigate to the next or previous
worksheet  

Grouping Worksheets 
By grouping worksheets you are able to apply certain formatting and formulas to multiple worksheets.
This can save a great amount of time. The only requirement is that the region in which you wish to make
modifications across the grouped worksheets needs to be set out in the same format.

Select Worksheets in a Range 

Method
1. Select the 
first worksheet

2. Hold down Shift and select the last worksheet of the range

3. To de-select, select a worksheet that has NOT been selected

Select Non-Adjacent Worksheets  

Method
1. Select the first worksheet

2. Hold down Ctrl and select the additional worksheets 

3. To de-select, select a worksheet that has NOT been selected

Select all Worksheets  

Method 

1. Right click on any worksheet tabs, select, Select All Sheets 

2. To de-select, right click on any of the worksheet tabs and select Ungroup sheets 

You can always de-select grouped worksheets by right clicking the worksheet tabs and selecting 
Ungroup sheets, no matter how you grouped them.
Exercise: Working with cells and worksheets 

Open file: Working with cells and worksheets.xlsx 

Steps 
Insert 
five new worksheets to the workbook

Select Sheet 1

Select range (B2:C2) 

Click on [Home][Alignment][Merge & Center] 

Rename Sheet 1 to First

Copy the First worksheet twice

Rename the new worksheets Second and Third and move them into order 
Select the merged cell B2 on Second. Change it to My Sheet 2

Select the merged cell B2 on Third. Change it to My Sheet 3

Delete worksheets Sheet 2 and Sheet 3

Select worksheet First

Hold Ctrl and select the worksheet tabs for worksheets Second and Third
Select the merged cell B2 on the First worksheet

Change the format to red text, yellow highlight and a frame

If you now look at the Second and Third worksheets the formatting of B2 should be the same
as in the First worksheet

Solution 

Worksheet Protection

To prevent a user from accidentally or deliberately changing, moving, or deleting important data from a
worksheet or workbook, you can protect certain worksheet or workbook elements, with or without a
password. You can remove the protection from a worksheet as needed. 

When protecting the worksheet, you must first unlock the cells that you want to edit and then protect the
worksheet  

To ensure the person using the worksheet cannot copy the data and paste it to another workbook you
must de-select “Select locked cells” in the Protection dialogue box. 

Unlock Cells  

The cells that you unlock are the cells that you will be able to edit after protecting the worksheet.  

Method 

1. Select the cells, columns or rows that can be edited
2. From the Home tab, in the Cells group select Format
3. Select Lock Cell from the list 

The icon does not change; you either select it or de-select it by clicking on it  

OR  

1.  Select the cells, columns or rows that can be edited 

2.  Right click and select Format Cells… 

3. On the Format Cells dialogue box select the Protection tab 

4. De-select the Locked option 

5. Click on OK 

Note: You can Lock the cells again by following the steps above.  

Protect the Worksheet 

Method
1.  From the Home tab, in the Cells group, select Format 

2. Select Protect Sheet from the list 

3.  Ensure you de-select
 Select locked cells

This will ensure the worksheet cannot be copied and pasted 

4.  Enter a password or leave blank

5. Select OK

Unprotect the Worksheet 

Method
1.  From the
 Home tab, in the Cells group, select Format

2. Select Unprotect Sheet from the list

3.  Enter the password if necessary

4. Select OK

Note: You can also right click the worksheet tab and Protect/Unprotect your worksheets. 
Exercise: Worksheet protection 

Open file: Worksheet protection.xlsx 

Steps 
Select the yellow, highlighted 
Section A on the Sections worksheet (D4:D19) 
Click on [Home][Cells][Format][Lock Cell] 

Click on [Home][Cells][Format][Protect Sheet] 

Make sure only the Select unlocked cells option is selected. Don't enter a password
Now you should only be able to enter information into the yellow highlighted Section A

Click on [
Home][Cells][Format][Unprotect Sheet] 

The sheet will now be unprotected again

Select the yellow, highlighted Section A on the Sections Worksheet (D4:D19) 
Click on [Home][Cells][Format][Lock Cell] 

Select the green highlighted Section B on the Sections Worksheet (G4:G19) 
Click on [Home][Cells][Format][Lock Cell] 

Click on [Home][Cells][Format][Protect Sheet] 

Make sure only the Select unlocked cells option is selected. Don't enter a password
Now you should only be able to enter information into the green highlighted Section B

Paste Special

Using the
 Paste Special dialogue box when pasting your copied data, you have the option to select 
specific contents of the copied data, which you would like to paste to the destination area, including
options to do mathematical calculations, not replacing blank copied cells and transposing the data.

All
Formulas
Values

Formats

Comments 

Validation 
PASTE
Paste all the stuff in the cell selection (formulas, formatting, etc.). This is
what happens when you paste normally.

Paste all the text, numbers, and formulas in the current cell selection
without their formatting. 

Convert formulas in the current cell selection to their calculated values. 
Paste only the formatting from the current cell selection, without the cell
entries.

Paste only the notes that you attach to their cells (like electronic post-it 
notes). 

Paste only the data validation rules into the cell range that you set up with 
the Data Validation command.

All using
 Paste all the information plus the cell styles applied to the cells. Source theme
All except 
borders

Paste all the stuff in the cell selection without copying any borders you
use there.

Column widths
 Apply the column widths of the cells copied to the Clipboard to the
columns where the cells are pasted.

Formulas and
number 

formats

Values and
number 

formats

Include the number formats assigned to the pasted values and formulas.

Convert formulas to their calculated values and include the number
formats you assigned to all the copied or cut values.

All merging
conditional
formats

Paste conditional formatting into the cell range.

None 

Add/subtract 
etc.
OPERATION 

Excel performs no operation between the data entries you cut or copy to
the Clipboard and the data entries in the cell range where you paste. This 
is the default setting. 

Excel adds, subtracts, multiplies or divides the values you cut or copy to
the Clipboard to the values in the cell range where you paste.

Skip blanks 

Transpose 
Paste Link
Select this check box when you want Excel to paste only from the cells 
that aren't empty. 

Select this check box when you want Excel to change the orientation of 
the pasted entries. For example, if the original cells' entries run down the
rows of a single column of the worksheet, the transposed pasted entries
will run across the columns of a single row.

PASTE LINK
Click this button when you want to establish a link between the copies
you're pasting and the original entries. That way, changes to the original 
cells automatically update in the pasted copies.

Method
1. Select the cells/range you want to copy

2. From the Home tab, in the Clipboard group, select Copy

3. Select the destination cell 

4. From the Home tab, in the Clipboard group, select the drop down arrow under Paste

5. Select Paste Special…

6. Make your selection as stated above
7. Click OK 

OR
1. Select the cells/range you want to copy.
2. Press Ctrl & C 

3.  Select the destination cell 

4. Right click your mouse 

5.  Either click on Paste Special to bring up dialog box or select one of the icons that represent
you option 

Short cuts: You can use Ctrl & C to Copy, Ctrl & X to Cut, Ctrl & V to Paste and Ctrl & Alt & V to
bring up the Paste Special dialogue box. 
Exercise: Paste Special

Open file: Paste Special.xlsx 

On the West worksheet  

Steps 
Select the data on the 
West worksheet (A1:J5) 

Copy the data

Select cell A1 on the New West worksheet 

Use Paste Special and Transpose the paste the data here 

The data in New West worksheet should now look the same as the data on East worksheet 

On the Combined worksheet  

Steps 
Select the data on the 
New West worksheet (A2:E10) (Do not copy the heading in Row1) 
Copy the data

Select cell A2 on the Combined worksheet 

Use
 Paste Special and Paste Link the paste the data here

The data in Combined should now look the same as the data on New West
Select the data on the East worksheet (A2:E19) (Do not copy the heading in Row1) 
Copy the data

Select cell A11 on the Combined worksheet

Use
 Paste Special and Paste Link the paste the data here

The data in Combined should now look the same as the data on New West as well as East
If you now change any on the data lines on New West or East, you should see that change
reflected on the Combined worksheet

Solution 

New West worksheet
Combined worksheet 

Nesting Functions

In certain cases, you may need to use a function as one of the arguments of another function. For 
example, the following formula uses a nested AVERAGE function and compares the result with the value
50.

The AVERAGE and SUM functions are nested within the IF function.  

Valid returns
When a nested function is used as an argument, the nested function must return the same type of value
that the argument uses. For example, if the argument returns a TRUE or FALSE value, the nested
function must return a TRUE or FALSE value. If the function doesn't, Excel displays a #VALUE! error
value.

A formula can contain up to sixty-four (64) levels of nested functions. 

Insert a Function within a Function 

Method
1. From the 
Formulas tab, in the Function Library group, select the Insert Function button

2. Select the first function that you are going to be using e.g. IF

3. Select the argument into which you wish to insert the nested function

4. To insert the nested function, on the left of the formula bar click on the drop down arrow to
get a list of the most recently used functions

5.  Either
 select the function you want to use, or select More Functions

6.  The switch back to your original formula, select it on the Formula bar

You can add a formula in one of three ways: 

1. Type the formula, start with an equal (=) sign, Excel will guide you further  

2. Select the function you want from the Function Library on the Functions tab  

3. Click on the insert function button  

next to the formula bar 

The last two methods will also provide you with a dialogue box to guide you through your formula.
Absolute Referencing

Normally there is not a problem when you copy formulas. But you may get an error if you are referring 
to a fixed cell. If you do not fix your reference to cells in your formula, the reference will move relative 
to the new position you copy the formula to. If C1 contains a formula A1*B1 and you copy the formula 
to C2 the formula will not stay A1*B1, it will become A2*C2. If you now want all the formulas you copy
to multiply by B1, you have to make that reference absolute. 

So an Absolute reference is a fixed reference and a Relative reference is not.  

Method
1. Select the cell where you want to enter the formula

2. Create your formula in the way you usually do 

3. In your formula as you type it in the formula bar, press F4 just after the cell you want to fix (the
reference will become =$A$1) 

4. The dollar signs show that the reference is fixed on column A and Row 1

5. If you now copy or AutoFill your formula you should not get any errors

You can also add 
Absolute referencing afterwards by selecting in the cell reference inside the formula
bar and then pressing F4. This functionality also works in formula dialog boxes. When you press F4 it
will fix different parts of the reference. First press will be both row and column fix. If you press it more 
times you can choose to only fix on a row or a column or revert back to relative referencing (no dollar
signs)

Exercise: Absolute Referencing

Open file: Absolute Referencing.xlsx 

Steps 
Select cell
 B5 on the Prices sheet

Enter the formula to get the amount exclusive of VAT

=A5*(1/(1+B1))

Use either the Fill handle or Copy & Paste to copy the formula up to cell B12
You will observe that the results either do not make sense or contains an error 
Select cell B5

Click on B1 in the formula bar and press F4. The formula should read as follows now: 
=A5*(1/(1+$B$1))

Use either the Fill handle or Copy & Paste to copy the formula up to cell B12
The errors should now be corrected

Solution
Logical Functions 

Logical functions return a TRUE or FALSE result. They are useful when testing the criteria of data. Based
on that result you are able to do further analysis. 

IF Function
The 
IF function returns one value if a condition you specify evaluates to TRUE, and another value if that 
condition evaluates to FALSE. For example, the formula =IF(A1>10,"Over 10","10 or less") returns
"Over 10" if A1 is greater than 10, and "10 or less" if A1 is less than or equal to 10. 

Syntax: 

logical_test 

value_if_true
value_if_false
=IF(logical_test, [value_if_true], [value_if_false]) 

Required. Any value or expression that can be evaluated to TRUE or
FALSE. For example, A10=100 is a logical expression; if the value in cell
A10 is equal to 100, the expression evaluates to TRUE. Otherwise, the
expression evaluates to FALSE.

Optional. The value that you want to be returned if thelogical_test
argument evaluates to TRUE. For example, if the value of this argument is
the text string "Within budget" and the logical_test argument evaluates to
TRUE, the IF function returns the text "Within budget." If logical_test
evaluates to TRUE and the value_if_true argument is omitted (that is, there 
is only a comma following the logical_test argument), the IF function returns
0 (zero). To display the word TRUE, use the logical value TRUE for the
value_if_true argument.

Optional. The value that you want to be returned if the logical_test
argument evaluates to FALSE. For example, if the value of this argument is
the text string "Over budget" and the logical_test argument evaluates to
FALSE, the IF function returns the text "Over budget." If logical_test
evaluates to FALSE and the value_if_false argument is omitted, (that is, 
there is no comma following the value_if_true argument), the IF function
returns the logical value FALSE. If logical_test evaluates to FALSE and the 
value of the value_if_false argument is blank (that is, there is only a comma
following the value_if_true argument), the IF function returns the value 0 
(zero). 

Method

1.  Start the formula by typing an equal (
=) sign in the cell followed by IF and an open bracket   
=IF(…

2.  Excel will then prompt you to complete the variables. Optional Variables will be shown in square 
brackets

OR 
1.  On the 
Formulas tab, in the Function Library group, click Logical

2. Select the IF function

3.  Complete the dialog box as shown above 

OR  

1. Click on the Insert Function button 

2. On the Insert Function dialog box, select the Logical category, then select the IF function from
the list of functions 

3. Click OK 

4. Complete the IF dialog box as shown above  

AND Function 

Returns TRUE if all its arguments evaluate to TRUE; returns FALSE if one or more arguments evaluate
to FALSE. 
One common use for the 
AND function is to expand the usefulness of other functions that perform logical
tests. For example, the IF function performs a logical test and then returns one value if the test evaluates 
to TRUE and another value if the test evaluates to FALSE. By using the AND function as the logical_test
argument of the IF function, you can test many different conditions instead of just one.

Syntax:
=AND(logical1, [logical2], ...)  

Required. The first condition that you want to test that can evaluate to eitherlogical1
TRUE or FALSE.  

logical2, ... 

 Optional. Additional conditions that you want to test that can evaluate to
either TRUE or FALSE, up to a maximum of 255 conditions.  

Method
1.  Start the formula by typing an equal (
=) sign in the cell followed by AND and an open bracket
=AND(…

2.  Excel will then prompt you to complete the variables. Optional Variables will be shown in square 
brackets

OR 
1.  On the 
Formulas tab, in the Function Library group, click Logical

2. Select the AND function

3.  Complete the dialog box as shown above 

OR  

1. Click on the Insert Function button 

2. On the Insert Function dialog box, select the Logical category, then select the AND function
from the list of functions  

3. Click OK 

4. Complete the AND dialog box as shown above 

OR Function 

Returns TRUE if any argument is TRUE; returns FALSE if all arguments are FALSE. 

Syntax: 

logical1, 
logical2, ...
= OR(logical1, [logical2], ...)  

Logical1 is required, subsequent logical values are optional. 1 to 255
conditions you want to test that can be either TRUE or FALSE.  

Method
1.  Start the formula by typing an equal (
=) sign in the cell followed by OR and an open bracket 
=OR(…

2.  Excel will then prompt you to complete the variables. Optional Variables will be shown in square 
brackets

OR 
1.  On the 
Formulas tab, in the Function Library group, click Logical

2. Select the OR function

3.  Complete the dialog box as shown above 

OR  

1. Click on the Insert Function button 

2. On the Insert Function dialog box, select the Logical category, then select the OR function
from the list of functions  

3. Click OK 

4. Complete the OR dialog box as shown above 

IFERROR Function 

IFERROR returns a value you specify if a formula evaluates to an error; otherwise, returns the result of 
the formula. You would use the IFERROR function to trap and handle errors in a formula. 

The following error types are evaluated: #N/A, #VALUE!, #REF!, #DIV/0!, #NUM!, #NAME?, or #NULL!.  

Syntax:
= IFERROR(value, value_if_error) 

Required. The argument that is checked for an error. In other words, yourvalue
existing formula. 

value_if_error Required. The value to return if the formula evaluates to an error. 

Method
1.
 Select a cell with an existing formula. For example: =A2/B2

2. Click on the Formula bar in the formula itself

3. Edit the formula by adding the IFERROR function: 

=IFERROR(A2/B2, "Error in calculation") 

Note: It is easier to first enter a formula and then to add the IFERROR function afterwards, otherwise 
you may not pick up if your original formula had an error.
Exercise: Logical Functions 

Open file: Logical Functions.xlsx 

On the AND sheet 

Steps  

Get Sales by Department B in March 

Enter an AND function in cell C2. You can either type it in or use the function libraries and 
dialog box 

logical1
A2="B"  

logical2
MONTH(B2)=3 

The answer you get should be TRUE or FALSE 

Use either the Fill handle or Copy & Paste to copy the formula up to cell C30 

Get Sales by Department A in May 

Enter an AND function in cell D2. You can either type it in or use the function libraries and 
dialog box 

logical1
A2="A"  

logical2
MONTH(B2)=5 

The answer you get should be TRUE or FALSE 

Use either the Fill handle or Copy & Paste to copy the formula up to cell D30 

On the OR sheet 

Steps  

Valid board meetings should have either the CEO or the FD present 

Enter an OR function in cell C2. You can either type it in or use the function libraries and 
dialog box 

logical1
B2="CEO" 
logical2
B2="FD"  

The answer you get should be TRUE or FALSE 

Use either the Fill handle or Copy & Paste to copy the formula up to cell C30
On the IF sheet  

Steps  

Evaluate test scores and arrive at a result (Fail, Pass or Distinction) 

Enter an IF function in cell B6. You can either type it in or use the function libraries and dialog
box 
logical_test
A6<$C$1

value_if_true $A$1

value_if_false $A$2

You need to use absolute referencing here 

The answer you get should be Pass or Fail 

Use either the Fill handle or Copy & Paste to copy the formula up to cell B16 

Enter an IF function in cell C6. You can either type it in or use the function libraries and dialog
box 
logical_test
A6>$C$3

value_if_true $A$3

value_if_false "No Distinction" 

You need to use absolute referencing here 

The answer you get should be Distinction or No Distinction 

Use either the Fill handle or Copy & Paste to copy the formula up to cell C16  

Now combine the 2 formulas in D6 

Enter an IF function in cell D6. You can either type it in or use the function libraries and dialog
box 
logical_test
A6>$C$3

value_if_true $A$3

value_if_false "No Distinction" 

You need to use absolute referencing here
This is exactly as the formula in cell
 C6. So you could copy it from the formula bar in C6
Now copy the formula in the cell B6. Copy all but the equal sign (IF(A6<$C$1,$A$1,$A$2)) 
In the cell D6, select the text "No Distinction" and Paste the above over it.
The formula now reads as: 

=IF(A6>$C$3,$A$3,IF(A6<$C$1,$A$1,$A$2)) 

The answer you get should be Fail, Pass or Distinction
Use either the Fill handle or Copy & Paste to copy the formula up to cell D16 

On the Data sheet 

Steps  

Select cell C2 

Click inside the formula bar and edit the formula to: 

=IFERROR(A2/B2,"") 

Either use the fill functionality or copy and paste to copy the formula all the way to C8 

Solution 

AND worksheet 

OR worksheet  

IF worksheet 
Data worksheet 

VLOOKUP Function

You can use the
 VLOOKUP function to search the first column of a range (range: Two or more cells on
a sheet. The cells in a range can be adjacent or nonadjacent.) of cells, and then return a value from any
cell on the same row of the range. For example, suppose that you have a list of employees contained in
the range A2:C10. The employees' ID numbers are stored in the first column of the range, as shown in
the following illustration. 

If  you  know the employee's  ID  number, you  can use the
 VLOOKUP function to return either  the
department or the name of that employee. To obtain the name of employee number 38, you can use the
formula =VLOOKUP(38, A2:C10, 3, FALSE). This formula searches for the value 38 in the first column
of the range A2:C10, and then returns the value that is contained in the third column of the range and on
the  same row as the lookup  value ("Axel Delgado"). The V  in VLOOKUP stands for vertical. Use
VLOOKUP instead of HLOOKUP when your comparison values are located in a column to the left of the
data that you want to find.

Syntax  

VLOOKUP(lookup_value, table_array, col_index_num, [range_lookup]) 

The VLOOKUP function syntax has the following arguments:
lookup_value
 Required. The value to search in the first column of the table or range. The
lookup_value argument  can be  a value  or a reference. If  the value  you supply for  the
lookup_value argument is smaller than the smallest value in the first column of the table_array
argument, VLOOKUP returns the #N/A error value.

table_array Required. The range of cells that contains the data. You can use a reference to a
range (for example, A2:D8), or a range name. The values in the first column of table_array are 
the values searched by lookup_value. These values can be text, numbers, or logical values. 
Uppercase and lowercase text are equivalent. 

col_index_num Required. The column number in the table_array argument from which the
matching value must be returned. A col_index_num argument of 1 returns the value in the first
column in table_array;  a col_index_num of 2 returns  the  value in  the second  column in
table_array, and so on. 

range_lookup Optional. A logical value that specifies whether you want VLOOKUP to find an 
exact match or an approximate match: 

o
 If range_lookup is either TRUE or is omitted, an exact or approximate match is returned. 
If an exact match is not found, the next largest value that is less than lookup_value is
returned. 

If range_lookup is either TRUE or is omitted, the values in the first column of table_array must be 
placed in ascending sort order; otherwise, VLOOKUP might not return the correct value. 

If range_lookup is FALSE, the values in the first column of table_array do not need to be sorted.
o
 If the range_lookup argument is FALSE, VLOOKUP will find only an exact match. If there
are two or more values in the first column of table_array that match the lookup_value, 
the first value found is used. If an exact match is not found, the error value #N/A is
returned. 

Method
1. Start the formula by typing an equal (
=) sign in the cell followed by VLOOKUP and an open
bracket =VLOOKUP(…

2. Excel will then prompt you to complete the variables. Optional Variables will be shown in square 
brackets

OR
1. On the 
Formulas tab, in the Function Library group, click Lookup & Reference

2. Select the VLOOKUP function

3. Complete the dialog box as shown above 

OR 

1. Click on the Insert Function button 

2.  On the Insert Function dialog box, select the Lookup &  Reference category, then select the
VLOOKUP function from the list of functions  

3. Click OK 

4.  Complete the VLOOKUP dialog box as shown above
Note
: If range_lookup is FALSE and lookup_value is text, you can use the wildcard characters — the
question mark (?) and asterisk (*) — in lookup_value. A question mark matches any single character;
an asterisk matches any sequence of characters. If you want to find an actual question mark or asterisk,
type a tilde (~) preceding the character.

Exercise: VLOOKUP Function

Open file: VLOOKUP Function.xlsx 

Steps 
Select the
 Page Views worksheet 

Enter a VLOOKUP function in cell B2. You can either type it in or use the function libraries
and dialog box 

lookup_value
 A2

table_array
Pages!A2:B39
col_index_num 2 

range_lookup 0 

Fix the table_array reference (absolute reference) by using the F4 key in either the formula
bar or VLOOKUP dialog box 

Pages!$A$2:$B$39 

Use either the Fill handle or Copy & Paste to copy the formula up to cell B14 

Alternative Steps using a Named Range
Delete
 the formulas you added in the exercise above (Page Views, B2:B14) 
Select the data on the Pages worksheet (A2:B39) 

Click on [Formulas][Defined Names][Define Name] 

Set the name to PageList

Click
 OK

Enter a VLOOKUP function in cell B2. You can either type it in or use the function libraries
and dialog box 

lookup_value
 A2

table_array
PageList

col_index_num 2 

range_lookup 0 

(Remember you can see a list of defined names by pressing F3 in the formula bar

or dialog box)  

Use either the Fill handle or Copy & Paste to copy the formula up to cell B14  

(In the second alternative you do not have to fix the data as it refers to the Named Range
created) 
Named Ranges

Uses of Named Rages:
Instead of using a cell reference, use the named range in your formula

Use the named range in your hyperlink 

Use the named range for navigating your worksheets 

Naming rules: 
No Spaces

No cell addresses

Cannot begin with a number 

Maybe use underscore instead of a space

A 
name is a meaningful shorthand that makes it easier to understand the purpose of a cell reference,
constant, formula, or table, each of which may be difficult to comprehend at first glance. The following
show a common example of names and how they can improve clarity and understanding:

=SUM(C20:C30) can become 

=SUM(FirstQuarterSales) 

that is easier to read, maintain and protect. 

Naming a Cell  

Method 

1.  Select the cell you want to name 

2.  Select the Name Box and enter a name 

3.  Press Enter 

Using Column Headings to Name Columns  

This is useful when you have a list and want the name the column heading to be the name of the Named
Range.  

Method 

1.  Select the range cell you want to name. Including the column labels 

2.  From the Formulas tab, in the Defined Names group, select Create from Selection
3. Select Top row (assuming your headings are in the top row)  

4. Select OK 

Manually create a Name from a Selected Range 

You can also first select a block of data and the manually create a name referring to it. 

Method
1. Select the 
range cell you want to name. This can span multiple columns and rows

2. From the Formulas tab, in the Defined Names group, select Define Name

3. Complete the New Name dialogue box

4. Select OK 

Insert a Named Range in Formulas 

Method
1. Create your
 formula the way you would normally

2. From the Formulas tab, in the Defined Names group, select Use in Formula

3. From the list of existing range names, select the name you want to insert

OR 

1. Press F3 to get a list of all Named Ranges 

2. Select the Named Range and Select OK 

Editing a Named Range 

Method
1.  From the
 Formulas tab, in the Defined Names group, select Name Manager

2.  Select the Named Range you would like to edit

3. Select Edit 

4.  You can either change the name or change the cell reference in the Refers to 

5. Select OK 

6. Select Close 

Navigating Named Ranges 

Method
1. Select the drop down arrow in the Name Box
2. Select the Range Name you want to navigate to
Exercise: Named Ranges

Open file: Named Ranges.xlsx 

Steps 
Select cell
 B1 on the Prices sheet

Click in the Name Box (currently displaying B1) and enter VATRate as the new name
Select cell B5

Enter the formula to get the amount exclusive of VAT

=A5*(1/(1+VATRate)) 

Use either the Fill handle or Copy & Paste to copy the formula up to cell B12
The results should now be correct without you having to use Absolute Referencing
Select range (
A1:C6) on the Sales worksheet

Click on [Formulas][Defined Names][Create from Selection] 
Select Top row

Click OK

Select cell F2

Enter the formula:

=SUM(North) - Remember to press F3 when you need to enter North 

Select cell F3 

Enter the formula: 

=SUM(East) - Remember to press F3 when you need to enter East 

Select cell F4 

Enter the formula: 

=SUM(West) - Remember to press F3 when you need to enter West
Solution 

Prices worksheet
Sales worksheet 

Mathematical Functions 

SUMIF Function
You use the 
SUMIF function to sum the values in a range that meet criteria that you specify. For example,
suppose that in a column that contains numbers, you want to sum only the values that are larger than 5.
You can use the following formula:

=SUMIF(B2:B25,">5") 
In this example, the criteria are applied the same values that are being summed. If you want, you can
apply the criteria to one range and sum the corresponding values in a different range. For example, the
formula =SUMIF(B2:B5, "John", C2:C5) sums only the values  in the  range C2:C5,  where the 
corresponding cells in the range B2:B5 equal "John". 

Syntax:
range
=SUMIF(range, criteria, [sum_range])

Required. The range of cells that you want evaluated by criteria. Cells in
each range must be numbers or names, arrays, or references that contain
numbers. Blank and text values are ignored. 

Required. The criteria in the form of a number, expression, a cell reference, 
text, or a function that defines which cells will be added. For example, criteria
can be expressed as 32, ">32", B5, "32", "apples", or TODAY(). 

criteria
sum_range
Important Any text criteria or any criteria that includes logical or
mathematical symbols must be enclosed in double quotation marks ("). If the 
criteria are numeric, double quotation marks are not required.

Optional. The actual cells to add, if you want to add cells other than those
specified in the range argument. If the sum_range argument is omitted,
Excel adds the cells that are specified in the range argument (the same cells
to which the criteria is applied). 

Method

1. Start the formula by typing an equal (
=) sign in the cell followed by SUMIF and an open bracket  
=SUMIF(…

2. Excel will then prompt you to complete the variables. Optional Variables will be shown in square 
brackets

OR
1. On the 
Formulas tab, in the Function Library group, click Math & Trig 

2. Select the SUMIF function 

3. Complete the dialog box as shown above 

OR 

1. Click on the Insert Function button 

2. On the Insert Function dialog box, select the Math & Trig category, then select the SUMIF
function from the list of functions 

3. Click OK 

4. Complete the SUMIF dialog box as shown above 

AVERAGEIF Function  

Returns the average (arithmetic mean) of all the cells in a range that meet a given criteria.  

Syntax:
=AVERAGEIF(range, criteria, [average_range])  

Required. One or more cells to average, including numbers or names,range
arrays, or references that contain numbers.
Required. The criteria in the form of a number, expression, cell reference, or
text that defines which cells are averaged. For example, criteria can be
expressed as 32, "32", ">32", "apples", or B4. 

criteria

Important Any text criteria or any criteria that includes logical or 
mathematical symbols must be enclosed in double quotation marks ("). If the 
criteria are numeric, double quotation marks are not required.

average_range Optional. The actual set of cells to average. If omitted, range is used.  

Method
1.  Start the formula by typing an equal (
=) sign in the cell followed by AVERAGEIF and an open 
bracket   =AVERAGEIF(…

2.  Excel will then prompt you to complete the variables. Optional Variables will be shown in square 
brackets

OR 
1.  On the 
Formulas tab, in the Function Library group, click More Functions, Statistical

2. Select the AVERAGEIF function

3.  Complete the dialog box as shown above 

OR  

1. Click on the Insert Function button 

2. On the Insert Function dialog box, select the Statistical category, then select the AVERAGEIF
function from the list of functions 

3. Click OK 

4. Complete the AVERAGEIF dialog box as shown above
Exercise: SUMIF Function 

Open file: SUMIF Function.xlsx 

Steps  

Enter a SUMIF function in cell F3, you can either type it in or use the function libraries and
dialog box
range
$C$2:$C$28

criteria
E3

sum_range
$B$2:$B$28

Fix the range and sum_range reference (absolute reference) by using the F4 key
in either the formula bar or SUMIF dialog box

Use either the Fill handle or Copy & Paste to copy the formula up to cell F5
The totals for the Summary should be the same as the asset list 

Solution 

Conditional Formatting 

Use a conditional format to help you visually explore and analyse data, detect critical issues, and identify
patterns and trends. Conditional formatting helps you visually answer specific questions about your data.
You can apply conditional formatting to a cell range, a Microsoft Excel table, or a PivotTable report. 

The benefits of conditional formatting  

Whenever you analyse data, you often ask yourself questions, such as:
Where are the exceptions in a summary of profits over the past five years? 

What are the trends in a marketing opinion poll over the past two years? 

Who has sold more than 50,000 this month?

What is the overall age distribution of employees?

Which products have greater than 10% revenue increases from year to year?
Who are the highest performing and lowest performing students in the class?

Conditional formatting helps to answer these questions by making it easy to highlight interesting cells or
ranges of cells, emphasize unusual values, and visualize data by using data bars, colour scales, and icon
sets. A conditional format changes the appearance of a cell range based on conditions (or criteria). If the
condition is true, the cell range is formatted based on that condition; if the conditional is false, the cell
range is not formatted based on that condition.

Add Conditional Formatting 

Method
1. Select the 
cells for which you want to add conditional formatting

2. From the Home tab, in the Styles group, select Conditional Formatting

3. Select the rule you want to apply from the list 

4. Each rule is further divided into sub types, for example, Highlight Cells Rules
5.  Select the sub type, for example Greater Than…

6.  Enter the criteria, remember to complete the format requirements in the with box  

7. Select OK 

Add Conditional Formatting across Rows 

Method
1.  Select the
 entire range that you would like to apply the conditional formatting to

2.  From the Home tab, in the Styles group, select Conditional Formatting

3. Select New Rule from the list 

4.  In the Select a Rule Type, select Use a formula to determine which cells to format

5.  Enter your criteria ensuring you fix the column reference as below:

6. Select the 
Format… button 

7. Set the format parameters and select OK, OK

To ensure you apply the Conditional Formatting to the entire row:  

Highlight the entire table of data  

Select Use a Formula to determine which cells to format 

Fix your column reference e.g. =$C 

By doing this you will ensure that when the formula is applied to the other cells, it will continue to refer 
to the specified column $c, else it will only highlight the first column of data. 

Copy Conditional Formatting 

Method 

1. Select the cells that have the conditional formatting you want to copy
2. From the Home tab, select the Format Painter 

3. Select the cells you want to format 

4. Press ESC when you finished  

OR
1. Select the 
cells that have the conditional formatting you want to copy
2. Select copy

3. Highlight the destination cells

4. Right click and select Paste Special, Formats, OK

Change Conditional Formatting 

Method
1.  From the
 Home tab, in the Styles group, select Conditional Formatting

2. Select Manage Rules

3.  From the Conditional Formatting Rules Manager dialogue box, select the rule you wish to 
change 

4.  Select the Edit Rule box

5.  Make the required changes 

6. Select OK, OK

Remove Conditional Formatting  

Method
1.  From the
 Home tab, in the Styles group, select Conditional Formatting

2. Select Manage Rules

3.  Select the rule you want to remove

4.  Select the Delete Rule button

5. Select OK

Highlight Duplicates 

Method
1.  From the
 Home tab, in the Styles group, select Conditional Formatting

2. Select Highlight Cell Rules

3. Select Duplicate Values

4.  Complete the formatting requirements in the Duplicate Values dialogue box 

5. Select OK

Exercise: Conditional Formatting 

Open file: Conditional Formatting.xlsx 

Steps  

Select the cells B2:B21 on Sheet1 

Click on [Home][Styles][Conditional Formatting][Highlight Cells Rules][Duplicate Values…] 
Click
 OK

You should now see the values that have duplicates 

Select the cells
 C2:C21 on Sheet1

Click on [Home][Styles][Conditional Formatting][Highlight Cells Rules][Greater Than…] 

Enter 120 000 in the value box and select Green Fill with Dark Green Text 

Click OK 

You should now see the values greater than 120 000
Auditing a Formula 

The Formula Auditing group options can help to check worksheets to ensure the formulas are consistent
and have no errors. 

It is also useful when checking for accuracy or finding the source of an error can be difficult when the
formula uses precedent or dependent cells:  

Precedent cells are cells that are referred to by a formula in another cell e.g. if cell D10
contains the formula =B5, cell B5 is a precedent to cell D10.  

Dependent cells are cells that contain formulas that refer to other cells e.g. if cell D10 contains 
the formula =B5, cell D10 is a dependent of cell B5.  

Trace Precedent/Dependent Arrows 

Method
1. From the 
Formulas tab, in the Formula Auditing group, select Trace Precedents or Trace 
Dependents

2. All cells leading up to or being used in the formula will be displayed 

3. If the below icon is shown, it means that cells from another worksheet are being referenced 

4. To navigate to that particular worksheet, double click the dotted line  

5. The Go To dialogue box will be displayed  

6.  Select the Reference, select OK 

7.  You will be navigated to the worksheet with the cell references 

Remove Arrows 

Method 

1.  From the Formulas tab, in the Formula Auditing group, select Remove Arrows 

OR  

1.  Select the drop down arrow, select Remove Precedent Arrows or Remove Dependent 
Arrows 

Exercise: Auditing a Formula

Open file: Auditing a Formula.xlsx 

Steps  

Select cell F8 on Sheet1 

Click on [Formulas][Formula Auditing][Trace Precedents]  

The arrows will show which variables are used to calculate the value of cell F8
Click on [Formulas][Formula Auditing][Remove Arrows] 
Select cell 
D2 on Sheet1

Click on [Formulas][Formula Auditing][Trace Dependents] 

The arrows will show where cell
 D2 is used in a formula

Click on [Formulas][Formula Auditing][Remove Arrows] 

Select cell E5 on Sheet1

Click on [Formulas][Formula Auditing][Trace Precedents] 

The arrows will show which variables are used to calculate the value of cell E5
Double click the dotted line 

Select the reference in the 
Go To dialog box:

Click OK

You will now be navigated to the cell on Sheet2

PivotTables 

A PivotTable is useful to summarize, analyse, explore, and present summary data. A PivotChart can help
you visualize PivotTable summary data so that you can easily see comparisons, patterns, and trends.
Both enable you to make informed decisions about critical data in your enterprise.

A PivotTable is an interactive way to quickly summarise large amounts of data. Use a PivotTable to
analyse numerical data in detail and to answer unanticipated questions about your data. A PivotTable is
especially designed for:

Querying large amounts of data in many user-friendly ways. 

Subtotaling and aggregating numeric data, summarising data by categories and subcategories,
and creating custom calculations and formulas.

Expanding and collapsing levels of data to focus your results, and drilling down to details from
the summary data for areas of interest to you. 

Moving rows to columns or columns to rows (or "pivoting") to see different summaries of the
source data.

Filtering, sorting, grouping, and conditionally formatting the most useful and interesting subset of 
data to enable you to focus on the information that you want. 

Original Worksheet  

PivotTable 

PivotChart  

Concept and Layout
An important point to remember when working with PivotTables is that you are working within a layout 
slightly different to a normal Excel worksheet. A PivotTable has its own Ribbon and that alone provides
functionality specific to the PivotTable.

Although one can format a cell using the format tools on the Home tab of the Ribbon, a PivotTable
provides its own format cells option on its Ribbon as it is treated as a separate entity.  

A PivotTable has its own layout and is split up into 4 sections.  

Each of the above sections is used to show fields from the PivotTable source data, each sections having
its own purpose. 
Report Filter
This section assists in providing athird dimension to your data. It can also 
provide a more summarised/filtered view of the rest of the fields displayed
in other sections.

When placing a field in this section it therefore
 reduces the number of 
items within a PivotTable and in some instances prevents the PivotTable 
number of items limitation from being reached.

Column
Labels
Row Labels
If you include a Report Filter field in your PivotTable you can choose to
display the PivotTable pages on separate worksheets. Select the Options
tab under the PivotTable sub-group, select the drop down arrow next to 
the Options button on the PivotTable group and from here select Show
Report Filter Pages…. Excel will automatically replicate each page’s data
on a separate worksheet.

You would place fields in this section when you want to group the data by
specific field e.g. by customer. Your customers will appear in the columns
going across. 

You would place fields in this section when wanting to group the data by a
specific field. E.g. by Customer. Your customers will appear in the rows
going down. 

You would normally place fields in this section where their values are 
numbers such as a quantity or amount field e.g. Customer Sales. 

Values
Calculations such as sum, average, min, max etc. can be used on these
fields. This section has to contain at least one field. 

PivotTable Field List
The PivotTable Field List contains the fields available for your 
PivotTable, based on the fields in the
range that the PivotTable in based on. In addition, there are areas where you can add Report filters,
sections that list the row and column fields and a section for the values. 

Turn the Field List On/Off 
The
 PivotTable Field List is only visible while you are within the PivotTable. If you are within the
PivotTable and it is still not visible, right click and select Show Field List. You can also turn the field list 
on and off from the Ribbon.

Method 

1.  Select any cell in the PivotTable 

2.  From the Options tab, in the Show group, select Field List 

OR  

1.  Select any cell in the PivotTable 

2. Right click and select Show/Hide Field List
PivotTables are updated each time a 
field is added,  removed or moved to a different position. For
PivotTables based on large data sets, these actions can take some time to complete. If you would rather
manually update, select Defer Layout Update.  

PivotTable Ribbon  

The PivotTable is generated from the Insert tab on the Ribbon. From the PivotTable icon you can select
PivotTable or PivotChart. 

Once the PivotTable has been  inserted,  a PivotTable Tools Ribbon becomes available. The new 
Ribbon has 2 tabs, the Options tab and the Design tab.  

PivotTable Layout  

You  can  change the  general  settings  of  the PivotTable layout.  This  layout  will determine  how the
PivotTable will function and look. The different layouts are listed below.
By
 default, Excel puts your PivotTable in this format. It is used to keep
Compact
related data from spreading horizontally off the screen and to help minimise
Form 
scrolling. Beginning fields on the side are contained in one column and are 

indented to show the nested column relationship.  

Outline Form Used to outline the data in the classic PivotTable style. 

Tabular Form 

 Used to see all data in a traditional table format and to easily copy cells to
another worksheet. 

Method 

1. From the Design tab, in the Layout group select Report Layout 
2.  Select the needed Layout 

Create a PivotTable 

To create a PivotTable, you need to identify these two elements in your data: 

Have a list in Excel with data fields (headings) and rows of related data
Identify which fields are going into your design 

When selecting your data range and you know that the rows of the list will grow, ensure that you select 
extra rows with your selection. 

Click on column A and drag to the last column of the list. This will ensure you select the range down to
the last row in Excel. 

Also if your data has blank rows, you can still use it but you have to manually select all the data you
want to use. 

Method 

1. Select any cell in the data list 

2. From the Insert tab, in the Tables group, select PivotTable 

3. Make sure that Select a table or range is selected 

4. Make sure your data is listed in the
 Table/Range box 

5. Select where you want the PivotTable to go, either in the Existing Worksheet or New
Worksheet

6. Select OK

7. A blank PivotTable will now be displayed 

8.  In the
 Field List either select the fields you want in the Row Labels or drag them into the Row 
Labels area on the Field List box

9. Repeat for Report Filter, Column Labels and Values

Format a PivotTable 

PivotTable Styles
Now that you have the PivotTable designed, as you need it, you may want to format it to look more
professional. Excel provides a gallery of styles ready for you to use. You can also add or remove banding
of rows and columns.

Method
1. Select any
 cell in the PivotTable report 

2. Form the Design tab in the PivotTable Styles group, select one of the visible styles or scroll
through all the available styles

3. You can also click on the
 more button to see all the styles available. Or you can create your
own style by clicking on New Pivot Style… at the bottom of the list

4. To remove a format, select Clear at the bottom of the list

PivotTable Style Options
Another way to format your PivotTable is to use the Style Options. Style Options can get applied to a 
PivotTable that has had a Style applied or not. You can add or remove banding (alternating a darker 
and lighter background) of rows and columns. Banding makes it easier to read and scan data.

Method
1. Select any
 cell in the PivotTable

2. From the Design tab, in the PivotTable Style Options group, select the type of banding
required for either rows, columns or row or column headers

Remove/Add and Move Fields 
When selecting a field from the data area to move or remove, you need to select the field by placing the
mouse pointer on the border of the field and clicking when the pointer changes to a normal arrow
pointer.

Fields that appear in the PivotTable will have a tick in their check box on the Field List. De-selecting this 
check box will remove the field from the PivotTable. 

Remove a Field 

Method 

1.  From the Field List select the check box next to the field you wish to remove  

OR  

1.  From the Field List, select the drop down arrow next to the field
2. Select Remove Field 

Add a Field 

Method
1. Select the check box next to the field in the Field List 

OR 

1. Select the Field in the Field List and drag it to the desired area e.g. Report Filter
Move Fields within the Table 

Method 

1. From the Field List, drag the field to the desired area  

OR 

1. From the Field List, select the drop down arrow next to the field
2. Select Move Up, Move Down, etc. 

Changes to Source Data 

Once a PivotTable Report has been created, it can easily be updated if the data in the original worksheet 
(source data) changes.  

Method
1.  Select any cell in the PivotTable 

2.  From the Options tab, in the Data group, select Refresh 

3.  The table is now updated with the changes made to the source data 

OR  

1. Right click the PivotTable 

2. Select Refresh 

Filter a PivotTable Report
You can set the data that will be displayed in your PivotTable, based on the selections you set. You use 
the drop down arrows next to the headings to do this. Note that the icons change if you have filtered on
a Field.

Method 

1.  Select the drop down arrow on a field you wish to filter  

2.  Select the check boxes of the items you would like displayed 

3. Select OK 

4. To display all the items, select Select All
You can 
control whether the filter button is available by setting or clearing the Display field caption 
and filter drop downs check box in the Display tab of the PivotTable Option dialogue box, or by
clicking Field Headers in the Show group on the Options tab. 

You cannot filter by colour, font colour, or icon set in a PivotTable report or PivotChart report. 

If you select the Select All check box, it will either select all items or de-select all items. 

Field Settings in Row/Column Labels 

Once you have created your PivotTable with the necessary fields, you may want to adjust certain field 
settings. 

Turn off Subtotals or Change Calculation 

Method 

1. Select the desired field 

2. From the Options tab, in the Active Field group, select Field Settings 

OR 

1. Right Click on the field and select Field Settings 

2.  Select the Subtotals & Filters tab 

3. Select
 None to turn off subtotals for that particular field

4. Select Custom to change the method of calculation, and select the desired function e.g.
Average

5. Select OK

A quick way to turn off all subtotals: 

From the Design tab, in the Layout group, select Subtotals 

Select Do Not Show Subtotals 

Create a Custom Name  

You are able to adjust the field names in the PivotTable. If you change the name of the field in the
PivotTable, it will not affect the name in your source data.  

In the Values area, you may find that the PivotTable will automatically put in Sum of, in front of the 
fields name. 

Method 

1.  Select the desired field 

2. From the Options tab, in the Active Field group, select Field Settings 

OR
1. Select the desired
 field

2. Right click on the field and select Field Settings

3. Select the Custom Name box

4. Enter a new name 

5. Select OK 

OR
1. Select the cell that contains the field

2. Enter the new field name

3. Press Enter

A Custom Name has to be unique. If you already have a field with a name you wish to use again (in the
source data), then you can make it unique by adding a space after the name. 

Value Field Settings in Values
Cells within a Pivot Table can be formatted as you normally would, use the Value Field Settings dialogue
box. Besides this option, within a PivotTable you can use the Number Format button on the Field Settings
dialogue box to change the number format. This however will only display the number tab of the Format 
cells dialogue box so it cannot be used to change the font alignment etc.

Change Number Format 

Method 

1.  Select the desired field 

2.  From the Options tab, in the Active Field group, select Field Settings 

OR 
1.  Select the desired
 field

2. Right click on the field and select Field Settings

3. Select Number Format

4. Select the desired format

5. Select OK 

Data Drill Down
You may be working with a PivotTable and need to see further details of an amount in the Data area.
Often when a PivotTable is sent out, it  is sent without the source data to  ensure that there is no
modification of the source data.

Method 

1. In the Data Area of the PivotTable, double click on the amount you are wanting to drill into
2. A new worksheet will be inserted with the details making up that amount from the Data area 

Calculated Fields 

You can create your own calculated fields to include in your PivotTable but take note of the following 
important points 

You can use the same operators and expressions as you would in normal worksheet formulas
You cannot use cell references or defined names 

Method 

1.  From the Options tab, in the Calculations group, select Fields, Items, & Sets
2. Select Calculated Field… from the drop down menu 

3.  In the Name box enter the name 

4.  Select the field calculation: based on the
 Fields List

5. Select Insert Field

6. In the Formula box, edit the formula
7. Select Add

8. Select OK

Edit/Delete calculated field 

Method
1.  From the Options tab, in the Calculations group, select Fields, Items, & Sets
2. Select Calculated Field… from the drop down menu 

3.  In the Name box select the drop down arrow and select the field you would like to
edit/delete 

4.  Make the necessary changes or press Delete 

5. Select OK 

Changes to the Location/Area of the Source Data 

If you have added an extra column to the outside of the initial selected range, you will need to re-select
the PivotTable area.  

Method 

1.  Select any cell in the PivotTable 

2. From the Options tab, in the Data group, select Change Data Source 

3. Select the collapse button and re-select the data range 

4. Select OK 

It is possible to consolidate Data and PivotTables using the Consolidate Tool: 

From the Data tab, in the Data Tools group, select Consolidate 

Select the first range for the PivotTable, select Add 

Select additional ranges 

Select OK 
Exercise: PivotTables

Open file: PivotTables.xlsx 

Steps 

Select any cell within the data on the Sales worksheet
Click on [Insert][Tables][PivotTable]  

Click OK on the Create PivotTable dialogue box
Select the applicable fields as follows:  

Your results should be similar to: 

Select the
 Value Field Settings… of the Amount Excl VAT field 

Change the name to Sales and the number format to Accounting with no symbol
Center align the Sales heading

Sort the 
Sales data from highest to lowest values

Then collapse the Regionheadings

Apply any PivotTable style to your PivotTable

Clickon[PivotTable Tools Options][Calculations][Fields, Items & Sets][Calculated Field] 
Name:
 Cost Price

Formula: ='Amount Excl VAT'/125*100 (Remember to double click on Amount Excl VAT to 
use it, don't retype it) 

Format the heading the same as for Sales (Field name Cost Price, remember to add a space
as this name already exist) 

Clickon[PivotTable Tools Options][Fields, Items & Sets][Calculated Field] 
Name:
 Gross Profit

Formula: ='Amount Excl VAT' -'Cost Price' (Remember to double click on Amount Excl VAT
and Cost Price to use it, don't retype it)

Format the heading the same as for Sales

Double click an amount in the Head Office line, you should get a new worksheet with only the
Head Office data
Hyperlinks 

A hyperlink is link from a worksheet that goes to another worksheet or file when you select it. You can
hyperlink to any file, not just an Excel workbook. The hyperlink itself can be text or a picture. Hyperlinks
can also link to e-mail addresses or websites.

Method 

1. Select the item that you would like to create the hyperlink on 

2. From the Insert tab in the Links group, select Hyperlink 

3. To hyperlink to another worksheet in the workbook, select 
Place in This Document

4. Under Cell Reference, select the worksheet you would like to link to

5. Under Defined Names, select any named ranges that you would like to link to

6. On the top right, select Screen Tip and enter in any guidelines you need to give

7. Select OK

To quickly insert, edit or remove a hyperlink, right click on the item and select the desired option.
Exercise: Hyperlinks

Open file: Hyperlinks.xlsx 

Steps 
Select the
 Dashboard worksheet

Select cell B3 and enter MySheet 1

Select cell B4 and enter MySheet 2

Right click on cell B3 and add a hyperlink to the MySheet 1 worksheet

Click on the hyperlink in cell B3, it should navigate you to the MySheet 1 worksheet 
In cell A1 on the MySheet 1 worksheet, enter the word Home and create a hyperlink back to 
the Dashboard worksheet

Repeat the steps now in cell B4 on the Dashboard worksheet for MySheet 2

Solution 

Text Functions 

LEFT Function 

LEFT returns the first characters in a text string, based on the number of characters you specify. In other
words, you can specify the amount of characters you want returned from the left hand side of a text string. 

Syntax:
=LEFT(text, [num_chars])  

Text
Required. The text string that contains the characters you want to extract.
Optional. Specifies the number of characters you wantLEFT to extract.
Num_chars must be greater than or equal to zero.  
If num_chars is greater than the length of text, LEFT returns all of 
Num_charstext.  

If num_chars is omitted, it is assumed to be 1.  

Method
1. Start the formula by typing an equal (
=) sign in the cell followed by LEFT and an open bracket
=LEFT(….

2. Excel will then prompt you to complete the variables. Optional Variables will be shown in square 
brackets

OR
1. On the 
Formulas tab, in the Function Library group, click Text

2. Select the LEFT function

3. Complete the dialog box as shown above 

OR 

1. Click on the Insert Function button 

2.  On the Insert Function dialog box, select the Text category, then select the Left function from
the list of functions 

3. Click OK 

4.  Complete the LEFT dialog box as shown above 

The RIGHT function works the same as the LEFT function it just returns characters from the right hand 
side of a text string. 

MID Function  

MID returns a specific number of characters from a text string, starting at the position you specify, based
on the number of characters you specify. 
Syntax:
=MID(text, start_num, num_chars) 

Text
Required. The text string that contains the characters you want to extract.
Start_num

 Required. The position of the first character you want to extract in text. The
first character in text has start_num 1, and so on. 

Num_chars 

 Required. Specifies the number of characters you want MID to return from 
text.  

Method
1. Start the formula by typing an equal (
=) sign in the cell followed by MID and an open bracket
=MID(…

2. Excel will then prompt you to complete the variables. Optional Variables will be shown in square 
brackets

OR
1. On the 
Formulas tab, in the Function Library group, click Text

2. Select the MID function

3. Complete the dialog box as shown above 

OR 

1. Click on the Insert Function button 

2.  On the Insert Function dialog box, select the Text category, then select the MID function from
the list of functions 

3. Click OK 

4.  Complete the MID dialog box as shown above 

FIND Function  

FIND locate one text string within a second text string, and return the number of the starting position of 
the first text string from the first character of the second text string. 

Syntax:
= FIND(find_text, within_text, [start_num]) 

Find_text
Required. The text you want to find.  

Within_text Required. The text containing the text you want to find.
Optional. Specifies the character at which to start the search. The first
Start_num
character in within_text is character number 1. If you omit start_num, it is

assumed to be 1

Method

1. Start the formula by typing an equal (
=) sign in the cell followed by FIND and an open bracket  
=FIND(…

2. Excel will then prompt you to complete the variables. Optional Variables will be shown in square 
brackets

OR
1. On the 
Formulas tab, in the Function Library group, click Text

2. Select the FIND function

3. Complete the dialog box as shown above 

OR 

1. Click on the Insert Function button 

2.  On the Insert Function dialog box, select the Text category, then select the FIND function from
the list of functions 

3. Click OK 

4.  Complete the FIND dialog box as shown above 

Note: the FIND function is cAsE sEnSiTiVe.  

CONCATENATE Function 
The
 CONCATENATE function joins up to 255 text strings into one text string. The joined items can be
text, numbers, cell references, or a combination of those items. For example, if your worksheet contains
a person's first name in cell A1 and the person's last name in cell B1, you can combine the two values in
another cell by using the following formula:

=CONCATENATE(A1," ",B1)  

The second argument in  this example (" ") is a space character. You must specify any spaces or
punctuation that you want to appear in the results as an argument that is enclosed in quotation marks.
Syntax1: 
= CONCATENATE(text1, [text2], ...) 

Syntax2: 
= text1 & “ “ & text2

Text1
Required. The first text item to be concatenated.

Text2,…

Optional. Additional text items, up to a maximum of 255 items. The items
must be separated by commas. 

If you use Syntax2 (&), text must be placed in double quotes. 

Method
1. Start the formula by typing an equal (
=) sign in the cell followed by CONCATENATE and an
open bracket = CONCATENATE (…

2. Excel will then prompt you to complete the variables. Optional Variables will be shown in square 
brackets

OR

1.  On the Formulas tab, in the Function Library group, click Text

2. Select the CONCATENATE function

3.  Complete the dialog box as shown above 

OR 
1. Click on the Insert Function button 

2.  On the Insert Function dialog box, select the Text category, then select the CONCATENATE
function from the list of functions 

3. Click OK 

4.  Complete the CONCATENATE dialog box as shown above 

TRIM Function  

TRIM removes all spaces from text except for single spaces between words. Use TRIM on text that you
have received from another application that may have irregular spacing.  

Syntax1: 
= TRIM(text) 

Method
1. Start the formula by typing an equal (
=) sign in the cell followed by TRIM and an open bracket
= TRIM (…

2. Excel will then prompt you to complete the variables. Optional Variables will be shown in square 
brackets

OR
1. On the 
Formulas tab, in the Function Library group, click Text

2. Select the TRIM function

3. Complete the dialog box as shown above 

OR 

1. Click on the Insert Function button 

2. On the 
Insert Function dialog box, select the Text category, then select the TRIM function from
the list of functions

3. Click OK

4. Complete the TRIM dialog box as shown above

LEN Function 

LEN returns the number of characters in a text string. 

Syntax1: 
= LEN(text)  

Method
1.  Start the formula by typing an equal (
=) sign in the cell followed by LEN and an open bracket   = 
LEN (…

2.  Excel will then prompt you to complete the variables. Optional Variables will be shown in square 
brackets

OR 
1.  On the 
Formulas tab, in the Function Library group, click Text

2. Select the LEN function

3.  Complete the dialog box as shown above 

OR  

1. Click on the Insert Function button 

2.  On the 
Insert Function dialog box, select the Text category, then select the LEN function from
the list of functions

3. Click OK

4.  Complete the LEN dialog box as shown above

TEXT Function 
The 
TEXT function converts a numeric value to text and lets you specify the display formatting by using
special format strings. This function is useful in situations where you want to display numbers in a more
readable format, or you want to combine numbers with text or symbols. For example, suppose cell A1
contains the date 23 April 2013. To format the date as a day word, you can use the following formula:

=TEXT(A1,"dddd") 

In this example, Excel displays Tuesday.  

Syntax1: 
=TEXT(value, format_text) 

Required. A numeric value, a formula that evaluates to a numeric value, or aValue
reference to a cell containing a numeric value.
Required. A numeric format as a text string enclosed in quotation marks, for
Format_text 
example "dddd" or "mmmm". See the following sections for specific 

formatting guidelines

m 
Displays the month as a number without a leading zero.
mm
Displays the month as a number with a leading zero when appropriate. 
mmm
Displays the month as an abbreviation (Jan to Dec).

mmmm
Displays the month as a full name (January to December).
mmmmm  Displays the month as a single letter (J to D).

d 
Displays the day as a number without a leading zero.

dd
Displays the day as a number with a leading zero when appropriate.
ddd 
Displays the day as an abbreviation (Sun to Sat).

dddd
Displays the day as a full name (Sunday to Saturday). 
yy
Displays the year as a two-digit number. 

yyyy 
Displays the year as a four-digit number.

In these examples the date formatting was used, you can use any cell formatting available in Excel in 
this function. 
Exercise: Text Functions 

Open file: Text Functions.xlsx 

On the Invoice List sheet 

Steps  

Obtain the document type 

Enter a LEFT function in cell C2. You can either type it in or use the function libraries and
dialog box 

text
A2 

num_chars
3  

The answer you get should be the first 3 letters INV 

Use either the Fill handle or Copy & Paste to copy the formula up to cell C30 

Obtain the invoice number 

Enter a RIGHT function in cell D2. You can either type it in or use the function libraries and
dialog box 

text
A2
num_chars
5  

The answer you get should be the last 5 numbers of the invoice
Use either the Fill handle or Copy & Paste to copy the formula up to cell D30 

Obtain the system the invoice was created from  

Enter a MID function in cell E2. You can either type it in or use the function libraries and
dialog box
text
A2
start_num
4 
num_chars
1 

The answer you get should be the either A or B depending on the invoice number
Use either the Fill handle or Copy & Paste to copy the formula up to cell E30 

Get the day of the week the invoice was generated 

Enter a TEXT function in cell F2. You can either type it in or use the function libraries and
dialog box 

value
B2
format_text
“dddd”  

The answer you get should be a day of the week 

Use either the Fill handle or Copy & Paste to copy the formula up to cell F30 

On the Customers sheet 

Steps  

Get the length of the Customer text 

Enter a LEN function in cell B2. You can either type it in or use the function libraries and
dialog box 

text
A2 

The answer you get should be the length of the customer field
Use either the Fill handle or Copy & Paste to copy the formula up to cell B9 

Find the location of the first space in the Customer field 

Enter a FIND function in cell C2. You can either type it in or use the function libraries and
dialog box 

find_text
“ “
within_text
A2 

The answer should be the location of the space in the customer field
Use either the Fill handle or Copy & Paste to copy the formula up to cell C9 

Get the surname value from the customer field 

Enter a RIGHT function in cell D2. You can either type it in or use the function libraries and
dialog box 

text
A2
num_chars
B2-C2 

The answer you get should be the surnames only  

Use either the Fill handle or Copy & Paste to copy the formula up to cell D9 

Get the length of the surname field (Column D) 

Enter a LEN function in cell E2. You can either type it in or use the function libraries and
dialog box 

text
D2
The answer you get should be the length of the surname value
Use either the Fill handle or Copy & Paste to copy the formula up to cell E9 

Get the name value from the customer field 

Enter a LEFT function in cell F2. You can either type it in or use the function libraries and
dialog box 

text
A2 

num_chars
B2-E2-1 

(The extra 1 subtracted here is to exclude the space between the name and surname, 
you could also use TRIM here)  

The answer you get should be the names only 

Use either the Fill handle or Copy & Paste to copy the formula up to cell F9 

Putting it all together 

Get the surname value from the customer field 

Enter a RIGHT function in cell I2. You can either type it in or use the function libraries and 
dialog box 

text
A2 

num_chars
LEN(A2)-FIND(" ",A2) 

The answer you get should be the surnames only 

Use either the Fill handle or Copy & Paste to copy the formula up to cell I9 

Get the name value from the customer field 

Enter a LEFT function in cell H2. You can either type it in or use the function libraries and
dialog box 

text
A2 

num_chars
LEN(A2)-LEN(I2)-1 

The answer you get should be the names only 

Use either the Fill handle or Copy & Paste to copy the formula up to cell H9
On the Addresses sheet 

Steps  

Combine the address parts to form a complete address 

Enter a CONCATENATE function in cell E2. You can either type it in or use the function
libraries and dialog box 

text
B2, " ", C2, ", ",D2 

The answer you get should be the combined address 

Use either the Fill handle or Copy & Paste to copy the formula up to cell E9 

Solution 

Invoice List  

Customers 

Addresses 

Working with Data Lists 

A data list is simply a list of data that has been entered in a series of rows with no blank rows in between.
Excel can then easily manage the data in many different ways by sorting, filtering, subtotalling and 
grouping. These are ways in which you may want to work with the data in the event that you however do
not want to use a PivotTable or cannot use one due to the limitation on the number of records you need 
to Pivot. 

These tools are very useful and assist with the performance of your work. 

When working with a data list you should keep the following in mind:
Never insert a blank row or column between your headings and your data otherwise they will not 
form part of the list

Rather format the column and row headings in a different way to the actual data in the list as
Excel can then easily detect if the list has row or column headings

Don’t place important information to the left or right of the list, this data could be hidden if you filter 
your data

Any blank  rows or columns will separate the data into separate data lists that operate
independently from each other 

Unhide any hidden rows or columns before making changes to the list to prevent you from
accidentally deleting them 

Spaces in the beginning or end of a cell will affect the sorting and searching, format the cells with
indents instead

Sorting Data

Sorting can either be done as a Single Level sort, where you sort only one column at a time or as a MultiLevel sort where you can sort up to 64 columns at the same time. 
You can sort data by text (
A to Z or Z to A), numbers (smallest to largest or largest to smallest), and
dates and times (oldest to newest and newest to oldest) in one or more columns. You can also sort by a
custom list (such as Large, Medium, and Small) or by format, including cell colour, font colour, or icon
set. Most sort operations are column sorts, but you can also sort by rows. 

Excel will sort data in the following manner in Ascending:
(space) 

! ” # & %

0 1 2 3 4 5

A B C D E F G H

Single Level Sorting 

You can use single level sorting for sorting a single column in either ascending or descending order.  

Method 

1. Select a cell in the column you wish to sort 

2. From the Home tab, in the Editing group, select Sort & Filter 

3. Select Sort A to Z or Sort Z to A 

Multi-Level Sorting 

Multi-level sorting allows you to sort up to 64 columns at a time.
Method
1.  Select any
 cell within the data list you wish to sort 

2.  From the Data tab, in the Sort & Filter group, select Sort

3.  Select the drop down arrow in the Column box and select the column you wish to sort

4.  Select the
 drop down arrow in the Sort On box and select the method you wish to sort by

5.  Select the drop down arrow in the Order box and select the sort order you wish to sort by

6.  Select the Add Level button to specify the next sort column

7.  Repeat steps 3 to 5

8.  Repeat steps 6 and 7 for subsequent columns 

9. Select OK

Set a Custom Sort Order  

The custom list feature allows the user to define a specific sort order. This means the user will be able to
sort a list in which ever order specified, not necessarily alphabetical or numerical. 

Method 

1. On a blank Excel worksheet, enter the sort order (text) as you would want it to be sorted
2.  Select the list you would like to base you Custom List on (as created in step 1) 
3. Select the Options under the File tab
4.  Select the Advanced category, then select the Edit Custom Lists… in the General grouping 
(near the end of the list) 

5. In the Custom Lists dialogue box, select Import. The copied list is pasted into the List entries
box 

6. Select
 OK, OK (The list is added to the custom list entries)

7. Select a cell in the column that you are wanting to sort

8. From the Data tab, in the Sort & Filter group, select Sort

9. Select the drop down arrow in the Sort On box and select the column you wish to sort

10. Select the drop down arrow in the Order box and select Custom List…

11. Select the specific custom list 

12. Select 
OK, OK

13. You can delete the custom list you created in step 1

Note: This new Custom Sort order is not limited to a specific workbook; it will be available to you the
next time you open another workbook as well. 

Sorting data by Rows 

Sometimes you need to sort your data in rows instead of columns.  

Method
1.
Select the data you wish to sort (excluding the headers in the first column)

2.  From the Data tab, in the Sort & Filter group, select Sort

3. Click on the Options… button

4. Select
 Sort left to right

5. Click OK

6. Now the Sort dialogue box will function as before but you will see Row options instead of 
Column options 

7. When you are done, click on OK and your data should be sorted in the row or rows you
specified

Note: If you need to return your data to its
 original state (the sort order you received or created it in) then
it is good practice to add an extra counting column so you can return the data to its original state by
sorting on this column.

Exercise: Sorting Data 

Open file: Sorting Data.xlsx 

Steps  

Select any cell in the Sales column
Click [Data][Sort & Filter][A to Z] 
The lowest sales will now be on top

Click [
Data][Sort & Filter][Sort] 

Sort the data by Date (oldest to Newest) and then by Sales (Largest to Smallest) 

Click
 OK

Click [
Data][Sort & Filter][Sort] 

Sort the data by # (Cell colour - yellow) and then by # (Cell colour - green) 

Click OK 

Exercise: Custom Sort order 

Open file: Sorting Data.xlsx 

Steps  

Select any cell in the City column
Click [Data][Sort & Filter][A to Z]  

The data will now be sorted in the following alphabetical City order: 
o
 Bloemfontein

o Cape Town 

o Durban

o East London

o George

o Johannesburg

o Kimberley

o Nelspruit

o Pretoria

Now we want to sort our data in the following City order (size of our branches):
o
 Johannesburg

o Pretoria

o Cape Town 

o Durban

o Bloemfontein

o East London

o Kimberley

o Nelspruit

o George

Select Sheet2 and type or copy the list in the order you want
Select the list you just created 

Click [
File][Options] 

Select the Advanced tab

Scroll to the bottom of the screen and select Edit Custom Lists… under the General heading

Click on Import 

Click on 
OK, OK

Select any cell in the data 

Click [Data][Sort & Filter][Sort] 

In the order drop down select Custom List…

Select your list and click OK, OK

The data is now sorted by your City order 

Subtotalling 

You can automatically calculate subtotals and grand totals in a list for a column by using the Subtotal
command. 

Create Subtotals 

Method
1.  Select any
 cell in the data list 

2. Sort the list by fields you want subtotals on

3.  From the Data tab, in the Outline group, select Subtotal 

4.  Select the
 drop down arrow in the At each change in box

5.  Select the sorted column (the one on which the subtotals will be based)

6.  Select the drop down arrow in the Use function box

7.  Select the function you want to use to calculate the subtotals, e.g. SUM

8.  Select the check boxes to place a tick mark for the columns that you want subtotals created in
the Add subtotal to box

9. Select Replace current subtotals if not already selected (This will replace any existing
subtotals in the worksheet)

If you are adding your 2nd level of subtotalling, you will de-select this option in order to add
the next level of subtotalling to the existing one

10. Select the Summary below data if not already selected (This will place the totals beneath each
grouping and not above) 

11. Select OK

You can now use the Expand/Collapse buttons the filter the data

Remove all Subtotals 

Method
1. Select any
 cell in the list

2. From the Data tab, in the Outline group, select Subtotal

3. Select Remove All

4. Select OK

Copying Subtotals 

If you use normal copy and paste, you will copy all the hidden information as well as the subtotals, but 
there is a way of copying just the subtotals as displayed. 

Method
1.
 Apply the necessary subtotals

2. Summarise your data by selecting the relevant level

3. Select the range of cells

4. From the Home tab, in the Editing group, select Find & Select

5. Select Go To Special…

6. Under
 Select, select Visible cells only

7. Select
 OK

8.  From the Home tab, in the Clipboard group, select Copy

9.  Select the position you want to copy to

10. From the Home tab, in the Clipboard group, select Paste

Exercise: Subtotalling

Open file: Subtotalling.xlsx 

Steps 
Add a
 multi-level sort on the data on the Data worksheet. Sort by Region and then 
Department

Click on [Data][Outline][Subtotal] 

Select the following options:

At each change in: 
Region

Use function: Sum

Add subtotal to: Amount Incl VAT and Amount Excl VAT

Replace current subtotals

Click OK 

Click on [Data][Outline][Subtotal] again  

Select the following options: 

At each change in:
 Department

Use function: Sum

Add subtotal to: Amount Incl VAT and Amount Excl VAT

Replace current subtotals NOT SELECTED 

Click OK 

Click on the third level of subtotalling 

Solution 

Copy the displayed results to Sheet2 

Steps 
Select
 the data you wish to copy

Click on [Home][Editing][Find & Select][Go To Special…] 
Select Visible cells only

Click
 OK

Click on [Home][Clipboard][Copy] 

Select cell A1 on Sheet2

Click on [Home][Clipboard][Paste] 

Solution 

SUBTOTAL Function 

The SUBTOTAL function returns a subtotal in a list or database. The SUBTOTAL function is very useful 
when you are filtering your list and wanting to calculate the filtered fields. 

Syntax:
=SUBTOTAL(function_num,ref1,[ref2],...])
Required. The number 1 to 11 (includes hidden values) or 101 to 111 
function_num
(ignores hidden values) that specifies which function to use in calculating

subtotals within a list. (9 is most commonly used – SUM) 

ref1

Required. The first named range or reference for which you want the
subtotal. 

ref2, …

Optional. Named ranges or references 2 to 254 for which you want the 
subtotal. 

Function_num 
Function_num
Function(includes hidden values)
(ignores hidden values) 

1 
101 
AVERAGE

2 
102 
COUNT 

3 
103 
COUNTA

4 
104 
MAX 

5 
105 
MIN

6 
106 
PRODUCT 

7 
107 
STDEV 

8 
108 
STDEVP

9 
109 
SUM 
10
110
VAR 
11
111
VARP 

Note: If there are other subtotals within ref1, ref2,… (or nested subtotals), these nested subtotals are
ignored to avoid double counting. 

Method
1. Start the formula by typing an equal (
=) sign in the cell followed by SUBTOTAL and an open 
bracket =SUBTOTAL(…

2. Excel will then prompt you to complete the variables. Optional Variables will be shown in square 
brackets

If you type the SUBTOTAL formula, you will get a drop down list from which you can select the function 
number/calculation method.  

OR
1. On the 
Formulas tab, in the Function Library group, click Math & Trig 

2. Select the SUBTOTAL function

3. Complete the dialog box as shown above 

OR 

1. Click on the Insert Function button 

2.  On the Insert Function dialog box, select the Math & Trig category, then select the 
SUBTOTAL function from the list of functions  

3. Click OK 

4.  Complete the SUBTOTAL dialog box as shown above 
Filtering Data 

Filtering data is a quick and easy way to find and work with a subset of data in a range of cells or table.
For example, you can filter to see only the values that you specify, filter to see the top or bottom values,
or filter to quickly see duplicate values. 

After you have filtered data in a range of cells or table, you can either reapply a filter to get up-to-date
results, or clear a filter to redisplay all of the data. Filtering doesn’t change your data in any way. As soon
as you remove the filter, all your data reappear, exactly the same as before. 

Filtered data displays only the rows that meet criteria that you specify and hides rows that you don't want 
displayed. After you filter data, you can copy, find, edit, format, chart, and print the subset of filtered data
without rearranging or moving it. 

You can also filter by more than one column. Filters are additive, which means that each additional filter
is based on the current filter and further reduces the subset of data that is shown. 

Note: When you use the Find dialog box to search filtered data, only the data that is displayed is
searched; data that is not displayed is not searched. To search all the data, clear all filters.
Using
 AutoFilter, you can create three types of filters: by a list of values, by a format, or by criteria. 
Each of these filter types is mutually exclusive for each range of cells or column table. For example, you 
can filter by cell colour or by a list of numbers, but not by both; you can filter by icon or by a custom filter,
but not by both. 

Excel will give you filtering option based on the data type in a column. For best results, do not mix storage
formats, such as text and number or number and date, in the same column because only one type of
filter command is available for each column. If there is a mix of storage formats in a column, the command
that is displayed is the storage format that occurs the most. For example, if the column contains three
values stored as number and four as text, the filter command that is displayed is Text Filters. 

Filter Options 

Number
Filter 

Text Filter
Date Filter 

You can also get the Top 10 option with a number filter. Here you can specify either the Top or Bottom
of the range and you can specify any number of items, not just 10.  

You can also select Custom for each type of filter and here you can set your own criteria.  

Apply AutoFilter 

Method 

1.  Select any cell within the data list you wish to filter 
2.  From the Data tab, in the Sort & Filter group, select Filter 

3. Drop down arrows will appear on each column heading 

4.  Select the drop down arrow in the column you want to filter on
5.  Select the check boxes for the items you would like to filter 
6. Select OK 

Once you have applied an AutoFilter you can also scroll down the data list and once you have found a
cell you would like to filter on you can Right click and filter the list in place:  

If your data have
 blank rows you can still use it, but you will have to manually select all the data
including the spaces first. 

If your data does not have headings AutoFilter will automatically assume that the first row of data is the
headings. To avoid this manually add headings or select the data and include one blank row above to
act as headings. 

Once the data is filtered in any way the column that were used will have a different icon and the data row
numbers will be in blue. Both of these indicators warn you that you might not be looking at all the data. 

Clear Filter  

This will clear the filter from a column or columns. 

Method 

1.  Select the drop down arrow of a filtered column 

2.  Select Clear Filter From “[Col]”  

OR  

1.  From the Data tab, in the Sort & Filter group, select Clear 

2.  This will clear all applied filters 

Remove AutoFilter 

Method 

1.  From the Data tab, in the Sort & Filter group, select Filter 

2. The drop down arrows will now be removed and all the underlying data will be visible again 

Advanced Filter Features
Advanced Filter enables you to set a complex set of criteria on which you can extract certain fields and
certain records to another worksheet. It is very useful when you do not want all the columns of the original
data extracted.

Advanced Filter is also helpful to extract either unique records or to remove duplicate values.
Method
1. Select the 
worksheet where you would like the data to appear 

2. Copy the relevant headings, with the criteria below 

3. Copy the headings where the extracted data must begin 

4. From the 
Data tab, in the Sort & Filter group, select Advanced

5. From Action, select Copy to another location

6. From List range, select the entire list range, including the headings from the source data

7. From Criteria range, select the headings and criteria

8. From Copy to, select the copied headings where the result will be placed 

9. Select OK
Exercise: Filtering Data

Open file: Filtering Data.xlsx 

Steps
Select cell
 E1 on the Data worksheet

Entera SUBTOTAL function in cell E1. You can either type it in or use the function libraries

and dialog box 

function_num 9  

ref1
E3:E9937 

The total of Col E will now be displayed above the data 

Select cell F1 on the Data worksheet  

Entera SUBTOTAL function in cell F1. You can either type it in or use the function libraries
and dialog box  

function_num 9  

ref1
F3:F9937 
The total of 
Col F will now be displayed above the data

Select any cell within the data list. (Say B15 for example) 

Click on [Data][Sort & Filter][Filter] 

The headings of the data will now have drop down boxes in them

Applya
 filter on the Number field. Use the [Number Filters][Between...] option and display
data where the Number is between 300 and 310

You should see the following:

Note that the
 Totals have adjusted due to the SUBTOTAL function

Also note the change in drop down icon for the Number field and that the row numbers are
blue now

Clickon[Data][Sort & Filter][Clear] 

All
 the data will display again

Apply a filter on the Amount Incl VAT field. Use the [Number Filters][Top 10...] option and
display the Bottom 5 items

You should see the following:

Note that the
 Totals have adjusted due to the SUBTOTAL function

Also note the change in drop down icon for the Amount Incl VAT field and that the row 
numbers are blue now

Clickon[
Data][Sort & Filter][Clear] 

All the data will display again

Apply a filter on the Date field. Display the first 10 days of January 2010 (Use the selection 
boxes)

You should see the following:

Note that the
 Totals have adjusted due to the SUBTOTAL function

Also note the change in drop down icon for the Date field and that the row numbers are blue
now

Exercise: Advanced Filtering 

Open file: Advanced Filtering.xlsx 

We want the filter the data on the data sheet to bring back the following data: 
All sales 
after 20 February 2012 AND

All sales from people with a surname Bender AND

All sales from people with a name of Patrick that are more than 1000 000

Steps  

Enter the criteria on the Advanced Filter worksheet 

Each
 new criterion is on a separate line

Make sure your date format is the same as your system format (you can check on the original
data to see your system format e.g. DD/MM/YYYY or YYYY/MM/DD) 

Click on [Data][Sort & Filter][Advanced] 

Select the following options:

Select 
Copy to another location

In the List range box, select somewhere in the original data on the Data tab and press Ctrl + A
In the Criteria range box select the cells A1:G4 (you must always select the headings as well) 
In the Copy to box, select the cells A6:G6

Click on OK

Solution

Group and Outline

If you have a list of data that you want to group and summarize, you can create an outline of up to eight 
levels, one for each group. Each inner level, represented by a higher number in the outline symbols
displays detail data for the preceding outer level, represented by a lower number in the outline symbols.
Use an outline to quickly display summary rows or columns, or to reveal the detail data for each group.
You can create an outline of rows, an outline of columns, or an outline of both rows and columns. 

Group rows and Columns 

Method 

1.  Select the rows or columns that contains the detailed data 

2.  From the Data tab, in the Outline group, select Group 

3. Repeat the steps above if you want to create more than one group 

Ungroup Parts of the Outline 

Method 

1.  Select the rows or columns that you would like to ungroup 

2.  From the Data tab, in the Outline group, select Ungroup  

Remove an Outline 

Method
1. Select any
 cell on the worksheet

2. From the Data tab, in the Outline group, select the drop down under Ungroup

3. Select Clear Outline

Adding or removing outlines does not affect the data on the worksheet. 

If you ungrouped data in its summarised form you may need to unhide those rows afterwards in
order to display them again. 
Exercise: Group and Outline 

Open file: Group and Outline.xlsx 

Steps 
Select cells
 C4 to E4

Click on [Data][Outline][Group] 

Select columns

Click OK

Select cells G4 to I4

Click on F4

Select cells K4 to M4

Click on F4

Select cells O4 to Q4

Click on F4

Click in the first level (1) to collapse the table
Select cells B4 to B7

Click on [Data][Outline][Group] 

Select rows

Click
 OK

Select cells B9 to B13

Click on F4

Click in the first level (1) to collapse the table

Working with Charts

Charts are used to display series of numeric data in a graphical format to make it easier to understand
large quantities of data and the relationship between different series of data.
Excel supports many types of charts to  help you display data in ways that are meaningful to your
audience. When you create a chart or change an existing chart, you can select from a variety of chart
types (such as a column chart or a pie chart) and their subtypes (such as a stacked column chart or a
pie in 3-D chart). You can also create a combination chart by using more than one chart type in your
chart.

Creating a Chart 

To create a chart, you can either use the Chart Tools or Press the F11 key. 

The Chart Tools are organised in the Design, Layout and Format tabs of the Chart Ribbon. By using
the Chart Tools, you can also create a chart by specifying your own series. 

You can create a chart from non-adjacent data on the worksheet. To do so, select the first range of
data, and then press the Ctrl key while you select the second range of data. Press F11.  

Method
1.
 Select the data you wish to use in your chart

2.  Press F11

3.  A default chart is created on a new worksheet that you can now edit

OR  

1. Select the data you wish to use in your chart 

2.  From the Insert tab, in the Charts group, select the chart type you want 

3.  A chart is created on the same worksheet that you can edit 

Once you have created a chart and select it, the Chart Ribbon will become visible with a Design, 
Layout and Format tab 

Design Tab 

The Design tab contains the functionality to:
Change your chart type

Switch rows and columns

Change series 

Apply some built in chart layouts and chart styles

Layout Tab 

The Layout tab contains the functionality to: 
Change the layout of the chart 

Change the format

Add titles

Add trend lines 

Change chart properties

Format Tab  

The Format tab contains the functionality to:  

Change the format of your chart 

Changing the Chart Type 

You might want to change your chart to another chart type.
Method 

1. Right click on the Chart Area 

2.  From the Shortcut menu select Change Chart Type 

3.  Select the new Chart Type 

4. Select OK 

You can also change the Chart Type from the Design tab on the Chart Ribbon.  

Changing the Location of a Chart  

You can move a chart to an existing worksheet or it can be placed on its own new sheet.
Method
1.
 Right click the Chart Area

2. From the Shortcut menu select Move Chart

3. Select the desired location 

4. Select OK 

You can also change the location of a chart from the Design tab on the Chart Ribbon.  

Edit Chart Labels 

Method 

1. Select the Chart 

2. From the Layout tab, in the Labels group, select the desired option 

3. The Chart will update automatically 

Specifying your own Series  

If you find that the data is not in sequence or a group of cells, you may need to create your own Series,
specifying the labels and values. 

Method
1. Select any
 blank cell on the worksheet

2. From the Insert tab, in the Charts group, select the desired Chart

3. A blank chart will then appear 

4.  From the Design tab, in the Data group, select Select Data

5. Delete the range in the Chart data range area (if there is something there)

6. Select Add in the Legend Entries (Series) box

7.  In the
 Series name box, you can either enter the name or select the red arrow and select the
cell for the name of the series

8.  In the Series values box select the red arrow and select the cells where the values are that you
want to chart 

9. Select
 OK

10. Select Add again if you are wanting to add another series

11. To put labels on the X axis (Bottom of the chart), select Edit in the Horizontal (Category) Axis 
Labels

12. In the Axis Label Range box select the red arrow 

13. Select the cells where you have the X axis labels e.g. Months, Branches 

14. Select OK, OK 

Creating a Chart with Two Independent axes 
Sometimes you have two sets of data that are very different in their scales. For example, one set of
data that are in the millions and another that are in the hundreds. For this kind of graph, you would like
two different axes to show.

Method 

1. Create you graph the way you would normally e.g. pressing F11
2. Select the data series of the smaller data set by clicking on it in the graph 

3. Right click and select Format Data Series… 

4. Select Secondary Axis, click Close 

5.  On the Chart Tools Design tab, Click on Change Chart Type in the Type group
6. Select another chart type e.g. Line graph and click OK 

7. You will now have a graph with two different axes  

Exercise: Working with Charts  

Open file: Working with Charts.xlsx
Steps 
Click anywhere in the data on
 Sheet1

Press F11

Click [Design][Type][Change Chart Type] 

Select a Line graph and click OK

Right click on the horizontal axis (Monday, Tuesday, etc.), select Format Axis…
Select the Alignment tab

Change the Text direction to Rotate all text 270

Click on Close

Click [Design][Location][Move Chart] 

Select Object in: Sheet1

Click OK

Solution 

Exercise: Dual Axes 

Open file: Dual Axes.xlsx 

Steps  

Click anywhere in the data on Sheet1 

Press F11 

Select on one of the 
Commission bar and right click, select Format Data Series…
Select Secondary Axis and click Close

Click [Design][Type][Change Chart Type] 

Select a Line graph and click OK

Click [Layout][Labels][Axis Titles][Primary Vertical Axis Title][Horizontal Title] to add a title
for Sales

Rename the title to 
Sales

Click [Layout][Labels][Axis Titles][Secondary Vertical Axis Title][Horizontal Title] to add a 
title for Commission

Rename the title to Commission

Solution 

Using comments 

You can add notes to a worksheet by using comments. Using comments can help you make a worksheet 
easier to understand by providing additional context for the data it contains. For example, you can use a
comment as a note that provides information about data in an individual cell. You can also add a comment
to a column heading to provide guidance on data that a user should enter. 

When a cell has a comment, a red indicator appears in the corner of the cell. When you rest the pointer 
on the cell, the comment appears. 
After you add comments, you can edit and format the text in comments, move or resize the comments,
copy them, display or hide them, or control how they and their indicators are displayed. When you no
longer need comments, you can delete them. 

Add a comment 

Method 

1. Select the cell that you want to add a comment to 

2. On the Review tab, in the Comments group, click New Comment  

3. In the body of the comment, type the comment text 

4. Click outside the comment box 

The comment box disappears, but the comment indicator remains 

OR
1. Select the cell that you want to add a comment to

2. Right click on your mouse or track pad

3. Select Insert Comment

4. In the body of the comment, type the comment text

5. Click outside the comment box

Keyboard shortcut:  You can also press SHIFT+F2 to add or edit a comment in a cell. 

Edit a comment 

Method 

1.  Select the cell that contains the comment that you want to edit
2.  On the Review tab, in the Comments group, click Edit Comment 

3.  In the comment text box, edit the comment text  

OR 
1.  Select the cell that contains the comment that you want to edit

2. Right click on your mouse or track pad

3. Select Edit Comment

4.  In the comment text box, edit the comment text 

Delete a comment  

Method 

1.  Click the cell that contains the comment that you want to delete
2.  On the Review tab, in the Comments group, click Delete 

OR 
1.  Click the cell that contains the comment that you want to delete

2. Right click on your mouse or track pad

3. Select Delete Comment

Display or hide comments on the worksheet 

Method 

1. Click the cell or cells that contain a comment indicator  

2. On the Review tab, in the Comments group, click Show/Hide Comment 

OR
1. Click the cell or cells that contain a comment indicator 

2. Right click on your mouse or track pad

3. Select Show/Hide Comments

Display or hide all comments on the worksheet 

Method 

1. On the Review tab, in the Comments group, click Show All Comments
2. Clicking Show All Comments again will hide all comments on the worksheet
Exercise: Using Comments 

Open file: Using comments.xlsx 

Steps  

On Sheet1 is a list of invoices, there are certain duplicates (4 duplicates, 8 cells) 
Insert the following comment on cells with the duplicate invoice numbers:  

Please Investigate the duplicate invoices 

Delete the comment on cell E2 

Click on [Review][Comments][Next] to cycle through the list of comments
Solution
Data Validation 

You use data validation to control the type of data or the values that users enter into a cell. For example,
you may want to restrict data entry to a certain range of dates, limit choices by using a list, or make sure
that only positive whole numbers are entered.

Data validation is an Excel feature that you can use to define restrictions on what data can or should be
entered in a cell. You can configure data validation to prevent users from entering data that is not valid.
If you prefer, you can allow users to enter invalid data but warn them when they try to type it in the cell.
You can also provide messages to define what input you expect for the cell, and instructions to help users
correct any errors. 

Data validation is invaluable when you want to share a workbook with others in your organization, and 
you want the data entered in the workbook to be accurate and consistent. 

Among other things, you can use data validation to do the following:
Restrict data to predefined items in a list.
 For example, you can limit types of departments to
Sales, Finance, R&D, and IT. Similarly, you can create a list of values from a range of cells
elsewhere in the worksheet.

Restrict numbers outside a specified range. For example, you can specify a minimum limit of
deductions to two times the number of children in a particular cell.

Restrict dates outside a certain time frame. For example, you can specify a time frame 
between today's date and 3 days from today's date. 

Restrict times outside a certain time frame. For example, you can specify a time frame for 
serving breakfast between the time when the restaurant opens and 5 hours after the restaurant
opens.

Limit the number of text characters. For example, you can limit the allowed text in a cell to 10
or fewer characters. Similarly, you can set the specific length for a full name field (C1) to be the
current length of a first name field (A1) and a last name field (B1), plus 10 characters.
Validate data based on formulas or values in other cells. For example, you can use data 
validation to set a maximum limit for commissions and bonuses of 3,600, based on the overall
projected payroll value. If users enter more than 3,600 in the cell, they see a validation
message.

Restrict data entry to values in a drop-down list  

Method
1.  On a separate worksheet, create the list of items you want to use in your drop down list 

2.  Create the form you would like people to complete on a different worksheet  

3.  Select the cell where you want the drop down box to appear (C3 in this example)
4.  From the Data tab, in the Data Tools group, select Data Validation 

5.  On the Data Validation dialogue box, under the Settings tab 

6.  In the
 Allow box, select List by clicking on the drop down arrow

7. Click on the red arrow under the Source box, select the list of data you created earlier 

8. Select OK

9. You can now select the needed value from a drop down list

If you copy and paste cell C3, the new cell will also have the drop down list available 

You can also validate the value of the cell in other ways as described above. You can get these options
by selecting other values from the Allow drop down list.  

Select an Input message for the Data Validation
You can choose to show an input message when the user selects the cell. Input messages are generally
used to offer users guidance about the type of data that you want entered in the cell. This type of message 
appears near the cell. You can move this message, if you want to, and it remains until you move to
another cell or press ESC.

Method 

1. Follow Steps 1 to 7 above 

2.  Select the Input Message tab on the Data Validation Dialogue box 

3.  Enter a
 Title and Input message to display

4. Click OK

5. Your Input Message will now appear when you select the cell

Select an Error Alert for the Data Validation 

You can also choose to show an error alert that appears only after users enter invalid data.
Method 

1. Follow Steps 1 to 7 above  

2. Select the Error Alert tab on the Data Validation Dialogue box 

3. Enter a
 Title and Error message to display

4. From the Style drop down list select a style of error message to display 

5. Click OK

6. Your Error Message will now appear when you enter incorrect data in the cell

Exercise: Data Validation

Open file: Data Validation.xlsx 

Steps 
Select 
Sheet2

Select the data range (B3:B10) 

Click [Formulas][Defined Names][Create from selection] 
Select Top row

Click OK

Select Sheet1

Select cell C3

Click [Data][Data Tools][Data Validation] 

Allow a List

In the Source box, click F3 and select Ratings

You should now be able to select a rating from the drop down list in the cell

Solution 

Goal Seek

If you know the result that you want from a formula, but are not sure what input value the formula needs
to get that result, use the Goal Seek feature. For example, suppose that you need to borrow some money.
You know how much money you want, how long you want to take to pay off the loan, and how much you 
can afford to pay each month. You can use Goal Seek to determine what interest rate you will need to
secure in order to meet your loan goal. Goal Seek works only with one variable input value.

Method 

1. Create a formula you want to evaluate, e.g. the PMT formula
For a formula like 
PMT, where you get the payments on a loan, it would not be easy to
determine the loan amount if you know the payment you could afford. Goal Seek allows you to 
find this amount for example.

2. From the Data tab, in the Data Tools group, select the drop down under the What-if Analysis
button and click on Goal seek…  

3. In the Goal Seek dialogue box, select the value you would like to change in the Set cell box 

4. Type the value you would like that cell to be in the
 To value box

5. Select the variable you would like to change in order to get your result in the By changing cell
box

6. Select OK

7. A Goal Seek Status dialogue box will now appear

8.  If you want to 
accept the new value as calculated by Excel, select OK
9.  If you do not want to accept the new value, click on Cancel

Exercise: Goal Seek

Open file: Goal Seek.xlsx 

Steps 
Sheet1
 contains a PMT formula and gives you a payment for a loan of 300 000, over 60 
months at an interest rate of 8% (-6 082.92) 

Select cell C10

Click on [Data][Data Tools][What-if Analysis][Goal Seek…]

On the Goal Seek Dialogue box:

Set cell:
 C10

To value: -4500

By changing cell: $C$4

Click OK 

Click OK on the Goal Seek Status dialogue box 

You will now have a new loan amount that will give you a payment of 4 500
Solution
Macros

To automate a repetitive task, you can quickly record a macro in Excel. You can also create a macro by
using the Visual Basic Editor in Visual Basic for Applications (VBA) to write your own macro script, or to
copy all or part of a macro to a new macro. After you create a macro, you can assign it to an object (such 
as a toolbar button, graphic, or control) so that you can run it by clicking the object. If you no longer use
a macro, you can delete it.

Record a Macro  

When you record a macro, the macro recorder records all the steps required to complete the actions that 
you want your macro to perform. Navigation on the Ribbon is not included in the recorded steps.  

Method 

1.  On the View tab, in the Macros group, click on the drop down arrow and select Record
Macro… 

You can also click in the record macro icon on the status bar  

2.  In the Macro name box, enter a name for the macro 

The first character of the macro name must be a letter. Subsequent characters can be letters, 
numbers, or underscore characters. Spaces cannot be used in a macro name; an underscore
character works well as a word separator. If you use a macro name that is also a cell reference, 
you may get an error message that the macro name is not valid

3. To assign a Ctrl combination shortcut key to run the macro, in the Shortcut key box, type any
lowercase letter or uppercase letter that you want to use 

The shortcut key will override any equivalent default Excel shortcut key while the workbook that 
contains the macro is open 

4. In the Store macro in list, select the workbook where you want to store the macro 

If you want a macro to be available whenever you use Excel, select Personal Macro 
Workbook
5. In the
 Description box, type a description of the macro

6. Click OK to start recording 

7. Perform the actions that you want to record

8. Click Stop Recording 

on the left side of the status bar  

OR 

On the View tab, in the Macros group, click on the drop down arrow and select Stop
Recording 

Run, Edit or Delete a Macro  

Method 

1. On the View tab, in the Macros group, click on the drop down arrow and select View Macros
2.  The macro dialogue box appears displaying all macros created 

3.  Select the macro you wish to run, edit or delete 

4. Select Run, Edit or Delete 

You can also view a list of macros by pressing Alt+F8 

Assign a macro to an object, graphic, or control  

Method
1.  On a worksheet, right-click the object, graphic, or control to which you want to assign an existing
macro, and then click Assign Macro

2.  In the Macro name box, click the macro that you want to assign

Relative Macro 

Unless you specify that a macro must be relative, it will run in the exact point when you recorded it. If you
want to macro to run in whatever cell is selected, you must make the macro relative.  

Method 

1.  On the View tab, in the Macros group, click on the drop down arrow and select Record
Macro… 

You can also click in the record macro icon on the status bar 

2. In the Macro name box, enter a name for the macro 

3. In the
 Store macro in list, select the workbook where you want to store the macro

4. In the Description box, type a description of the macro

5. Click OK to start recording 

6. On the View tab, in the Macros group, click on the drop down arrow and select Use Relative
References button

7. Perform the actions that you want to record 

8. Click Stop Recording 

on the left side of the status bar 
OR

On the View tab, in the Macros group, click on the drop down arrow and select Stop
Recording

Assign Macros to the Quick Access Toolbar
It is much quicker to access a function to the Quick Access Toolbar or keyboard than having to browse
through a number of menu items to select the one you need. So to have quicker access to run a macro
you can assign it to the Quick Access Toolbar.

Method 

1.  Open the Workbook that contains the macro 

2.  Select the drop down arrow at the end of the Quick Access Toolbar 

3. Select
 More Commands…

4.  Select the Choose commands from drop down and select Macros from the list

5. Select the macro you want to add from the command list

6. Select the Add >> button. The command will be added to the Quick Access Toolbar command

list

7. Select this new command 

8. Select the Modify… button 

9.  Select a Symbol and change the Display name

10. Select OK, OK
When you save a workbook that contains a macro you need to save it as a
 macro enabled workbook
(.xlsm file extension). And when you open this workbook again you need to enable the macros. This is 
done for security, DO NOT ENABLE MACROS ON A FILE YOU RECEIVED UNLESS YOU ARE 
100% SURE ABOUT ITS CONTENT. VIRUSES CAN BE SPREAD THIS WAY. 

Exercise: Macros

Open file: Macros.xlsx 

Steps  

Select cell B4 on Sheet1 

Click on the Macro Record button 

Enter the Macro name as MySig 

Enter the lowercase letter
 d next to the Ctrl +

Click on OK

Click on [View][Macros][Use Relative References] 

Enter data as follow on the screen (use your own contact details and required formatting)

Click on the Stop Macro recoding button when you are done 

Select any empty cell and press Crtl+d, your macro should now repeat your signature in the cell 
you selected 

Click the drop down arrow next to the Quick Access tool bar, select More Commands… 

Select Macros from the Choose commands from drop down list 

Select your
 MySig macro and click on Add>>

Click on the Modify… button

Select a new icon and change the display name to Signature, click OK, OK
When you click on the new icon in the Quick Access toolbar your macro will also run

Click on File, Save as… 

Select Excel Macro-Enabled Workbook from the Save as type drop down list 

Click on Save and close the file

Open the new file you have created

When you open a macro enabled workbook you will get the following message

If you want to run your macros, you will need to click on Enable Content 

DON’T CLICK ENABLE CONTENT IF YOU DO NOT KNOW WHAT MACROS ARE ON THE FILE
Excel Keyboard Shortcuts - Ctrl combination shortcut keys 

Key

CTRL+PgUp

CTRL+PgDn

CTRL+SHIFT+(
CTRL+SHIFT+&
CTRL+SHIFT&_
CTRL+SHIFT+~

CTRL+SHIFT+$
CTRL+SHIFT+%
CTRL+SHIFT+^
CTRL+SHIFT+#
CTRL+SHIFT+@

CTRL+SHIFT+! 

CTRL+SHIFT+* 

CTRL+SHIFT+: 

CTRL+` 

CTRL+SHIFT+"
Description

Switches between worksheet tabs, from left-to-right 
Switches between worksheet tabs, from right-to-left 
Un-hides hidden rows within the selection

Applies outline border to selected cells

Removes outline border from selected cells

Applies General number format

Applies Currency format with two decimal places (negative
numbers in parentheses) 
Applies Percentage format with no decimal places
Applies Scientific number format with two decimal places
Applies Date format with day, month, and year

Applies Time format with the hour and minute, and AM or PM

Applies Number format with two decimal places, thousands
separator, and minus sign (-) for negative values  

Selects current region around active cells. In PivotTables, it 
selects entire PivotTable reports 

Enters the current time 

Alternates between displaying cell values and displaying
formulas  

Copies value from cell above an active cell into the cell or the 
Formula Bar 
CTRL+SHIFT+Plus (+)
 Displays Insert dialog box to insert blank cells
CTRL+Minus (-)
Displays Delete dialog box to delete selected cells
CTRL+;
Enters current date

Copies a formula from the cell above the active cell into the cell CTRL+'
or the Formula Bar

CTRL+1
Displays Format Cells dialog box 

CTRL+2
Applies or removes bold formatting

CTRL+3
Applies or removes italic formatting

CTRL+4
Applies or removes underlining

CTRL+5
Applies or removes strikethrough

CTRL+6
Alternates between hiding and displaying objects
CTRL+8
Displays or hides the outline symbols 

CTRL+9
Hides selected rows 

CTRL+0
Hides the selected columns

CTRL+A

CTRL+SHIFT+A 

CTRL+B 

CTRL+C 

CTRL+D
CTRL+F

CTRL+SHIFT+F
CTRL+G

CTRL+H

CTRL+I

CTRL+K
CTRL+L

CTRL+N

CTRL+O

CTRL+SHIFT+O
CTRL+P

CTRL+SHIFT+P

CTRL+R 

CTRL+S
CTRL+T

CTRL+U

CTRL+SHIFT+U

CTRL+V 

CTRL+ALT+V
CTRL+W
CTRL+X
CTRL+Y

CTRL+Z
Selects entire worksheet 

Inserts argument names and parentheses when insertion point is 
to the right of function names in formulas
Applies or removes bold formatting

Copies selected cells

Uses Fill Down command to copy the contents and format of the 
topmost cell of a selected range into the cells below 
Displays Find and Replace dialog box, with the Find tab selected 
Opens Format Cells dialog box with the Font tab selected
Displays Go To dialog box 

Displays Find and Replace dialog box, with Replace tab selected
Applies or removes italic formatting

Displays Insert Hyperlink dialog box for new hyperlinks or Edit
Hyperlink dialog box for selected existing hyperlinks
Displays Create Table dialog box

Creates a new, blank workbook 

Displays Open dialog box to open or find a file

Selects all cells that contain comments

Displays Print tab in Microsoft Office Backstage view 
Opens Format Cells dialog box with the Font tab selected

Uses Fill Right command to copy the contents and format of the
leftmost cell of a selected range into the cells to the right
Saves the active file with its current file name, location, and file
format
Displays Create Table dialog box

Applies or removes underlining

Switches between expanding and collapsing of the formula bar 

Inserts contents of the Clipboard at the insertion point and 
replaces any selection. Available only after cutting or copying an 
object, text, or cell contents 

Displays Paste Special dialog box. Available only after cutting or 
copying an object, text, or cell contents on a worksheet or in
another program

Closes selected workbook window 

Cuts selected cells

Repeats last command or action, if possible

Uses Undo command to reverse the last command or to delete
the last entry that you typed

NOTE: The CTRL combinations CTRL+E, CTRL+J, CTRL+M, and CTRL+Q are currently unassigned
shortcuts

Excel Keyboard Shortcuts - Function keys

Key Description 

Displays the Excel Help task pane
CTRL+F1 displays or hides the ribbon 
F1

ALT+F1 creates an embedded chart of the data in the current range

ALT+SHIFT+F1 inserts a new worksheet
Edits the active cell and positions the insertion point at the end of the cell contents. It 
also moves the insertion point into the Formula Bar when editing in a cell is turned 
off.

F2 

SHIFT+F2 adds or edits a cell comment  

CTRL+F2 displays the print preview area on the Print tab in the Backstage view
Displays the Paste Name dialog box. Available only if there are existing names in
F3
the workbook. 

SHIFT+F3 displays the Insert Function dialog box 

Repeats the last command or action, if possible 

When a cell reference is selected in a formula, F4 cycles through all the various
F4
combinations of absolute and relative references.  

CTRL+F4 closes the selected workbook window 

ALT+F4 closes Excel
Displays the Go To dialog box

F5

CTRL+F5 restores the window size of the selected workbook window 

Switches between the worksheet, ribbon, task pane, and Zoom controls. In a
worksheet that has been split (View menu, Manage This Window, Freeze Panes,
Split Window command), F6 includes the split panes when switching between panes
and the ribbon area.

F6 

SHIFT+F6 switches between the worksheet, Zoom controls, task pane, and ribbon 

CTRL+F6 switches to the next workbook window when more than one workbook
window is open 

Displays the Spelling dialog box to check spelling in the active worksheet or 
selected range
F7
CTRL+F7 performs the Move command on the workbook window when it is not
maximized. Use the arrow keys to move the window, and when finished press 
ENTER, or ESC to cancel 

Turns extend mode on or off. In extend mode, Extended Selection appears in the
status line, and the arrow keys extend the selection 

SHIFT+8 enables you to add a nonadjacent cell or range to a selection of cells by
using the arrow keys
F8

CTRL+F8 performs the Size command (on the Control menu for the workbook
window) when a workbook is not maximized

ALT+F8 displays the Macro dialog box to create, run, edit, or delete a macro  

Calculates all worksheets in all open workbooks  

SHIFT+F9 calculates the active worksheet 

CTRL+ALT+F9 calculates all worksheets in all open workbooks, regardless of 
F9
whether they have changed since the last calculation 

CTRL+ALT+SHIFT+F9 rechecks dependent formulas, and then calculates all cells 
in all open workbooks, including cells not marked as needing to be calculated  

CTRL+F9 minimizes a workbook window to an icon
Turns key tips on or off. (Pressing ALT does the same thing.)
SHIFT+F10 displays the shortcut menu for a selected item 
F10

ALT+SHIFT+F10 displays the menu or message for an Error Checking button

CTRL+F10 maximizes or restores the selected workbook window 
Creates a chart of the data in the current range in a separate Chart sheet 

SHIFT+F11 inserts a new worksheet F11 

ALT+F11 opens the Microsoft Visual Basic for Applications Editor, in which you can 
create a macro by using Visual Basic for Applications (VBA)  

F12 Displays the Save As dialog box
Excel Keyboard Shortcuts - Miscellaneous

Key
Description 

Cancels an entry in the cell or Formula Bar 

Closes an open menu or submenu, dialog box, or message window 
ESC 

It also closes full screen mode when this mode has been applied, and 
returns to normal screen mode to display the ribbon and status bar again

Deletes one character to the left in the Formula Bar 

Also clears the content of the active cell
BACKSPACE

In cell editing mode, it deletes the character to the left of the insertion
point 

Removes the cell contents (data and formulas) from selected cells
without affecting cell formats or comments
DELETE

In cell editing mode, it deletes the character to the right of the insertion
point 

Moves to the beginning of a row in a worksheet 

Moves to the cell in the upper-left corner of the window when SCROLL
LOCK is turned on

Selects the first command on the menu when a menu or submenu is
HOME
visible 

CTRL+HOME moves to the beginning of a worksheet 

CTRL+SHIFT+HOME extends the selection of cells to the beginning of 
the worksheet 
END turns End mode on. In End mode, you can then press an arrow key
to move to the next nonblank cell in the same column or row as the
active cell. If the cells are blank, pressing END followed by an arrow key
moves to the last cell in the row or column. 

END also selects the last command on the menu when a menu or 
submenu is visible

END
CTRL+END moves to the last cell on a worksheet, to the lowest used 
row of the rightmost used column. If the cursor is in the formula bar,
CTRL+END moves the cursor to the end of the text

CTRL+SHIFT+END extends the selection of cells to the last used cell on
the worksheet (lower-right corner). If the cursor is in the formula bar,
CTRL+SHIFT+END selects all text in the formula bar from the cursor 
position to the end—this does not affect the height of the formula bar.

Moves one screen up in a worksheet 

ALT+PAGE UP moves one screen to the left in a worksheet
PAGE UP

CTRL+PAGE UP moves to the previous sheet in a workbook 
CTRL+SHIFT+PAGE UP selects the current and previous sheet in a
workbook

Moves one screen down in a worksheet 

ALT+PAGE DOWN moves one screen to the right in a worksheet
CTRL+PAGE DOWN moves to the next sheet in a workbook
PAGE DOWN 

CTRL+SHIFT+PAGE DOWN selects the current and next sheet in a 

workbook

Move one cell up, down, left, or right in a worksheet.

CTRL+ARROW KEY moves to the edge of the current data region in a 
worksheet.

SHIFT+ARROW KEY extends the selection of cells by one cell 
CTRL+SHIFT+ARROW KEY extends the selection of cells to the last
nonblank cell in the same column or row as the active cell, or if the next
cell is blank, extends the selection to the next nonblank cell.

ARROW KEYS 
ENTER 
LEFT ARROW or RIGHT ARROW selects the tab to the left or right
when the ribbon is selected. When a submenu is open or selected, these
arrow keys switch between the main menu and the submenu. When a
ribbon tab is selected, these keys navigate the tab buttons.

DOWN ARROW or UP ARROW selects the next or previous command 
when a menu or submenu is open.

When a ribbon tab is selected, these keys navigate up or down the tab
group. 

DOWN ARROW or ALT+DOWN ARROW opens a selected drop-down
list.
Completes a cell entry from the cell or the Formula Bar, and selects the
cell below (by default).  

In a data form, it moves to the first field in the next record.

Opens a selected menu (press F10 to activate the menu bar) or
performs the action for a selected command. 

SPACEBAR
ALT+ENTER starts a new line in the same cell 

CTRL+ENTER fills the selected cell range with the current entry 

SHIFT+ENTER completes a cell entry and selects the cell above
In a dialog box, performs the action for the selected button, or selects or 
clears a check box. 

CTRL+SPACEBAR selects an entire column in a worksheet 

SHIFT+SPACEBAR selects an entire row in a worksheet
CTRL+SHIFT+SPACEBAR selects the entire worksheet

If the worksheet contains data, CTRL+SHIFT+SPACEBAR 
selects the current region. Pressing CTRL+SHIFT+SPACEBAR a 
second time selects the current region and its summary rows. 
Pressing CTRL+SHIFT+SPACEBAR a third time selects the 
entire worksheet. 

When an object is selected, CTRL+SHIFT+SPACEBAR selects
all objects on a worksheet.

ALT+SPACEBAR displays the Control menu for the Excel window
Moves one cell to the right in a worksheet  

Moves between unlocked cells in a protected worksheet   

Moves to the next option or option group in a dialog box 

TAB 
SHIFT+TAB moves to the previous cell in a worksheet or the previous 
option in a dialog box  

CTRL+TAB switches to the next tab in dialog box  

CTRL+SHIFT+TAB switches to the previous tab in a dialog box 
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